How to send Ctrl+Shift+S to a pdf in Microsoft Edge?

Hi All

I want to save a pdf file from Microsoft Edge. For that I am passing Ctrl, Shift and S in Send Hot Ket activity.

But its throwing error: Special keys syntax error. Encountered invalid special key at text position: 21

Also I tried with TypeInto activity. But nothing is working.

How about just clicking the download icon?

there is no download button.

We are using Edge browser in IE mode.

@Palaniyappan @supermanPunch @lakshman

Hello @kkpatel
Can you share the screenshot of the workflow created and the screenshot of the application here?


Hi @kkpatel ,

Check the post below which describes the error and it’s possible resolution.

Let us know if it doesn’t help.

Kindly open and check. This post is just a question, there is no answer.

for save you can use ctrl+s enough

Hi @kkpatel

if you want to save PDF use Ctrl+S only.



none of them are working

So is this pdf opening in msedge after some click activity in the browser?

Yes, correct …


If your requirement is to download the pdf and if you are able to access url for the pdf file in edge browser.
Try using HTTP request pas the url as in endpoint and folder path in resource path.
package: uipath.webapi
Try this and let me know

Not getting a clear picture on this.

This url is automatically opened after clicking a button.

If I use the URl is http request how will it download into my local ?

Yes, if you can access the url with activities such as "get url’ or “get attribute”
and pass the url to http request in end point in properties and folder path in resource path. you can download to local

@kkpatel ,

Have you checked the Last Line in the above post shared ? I have highlighted in the below Screenshot :

Let us know if this is already done or tested and you’re still facing the issue.


Try this…

  1. Take one attach browser activity indicate it on the Edge - Make the selectors dynamic
  2. Take one send hotkey pass the CTRL+S (Don’t indicate it on the screen)

This will work for sure


Exactly ! It worked when I removed the attach activity and also the selectors from the Send Hot Key.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.