How to select non selectable menu items in a dropdown menu

studio

#1

Yes, I know, stupid question, but let me explain. We have a Windows application running in a network. It is possible to automate the different processes just fine. Apart from two dropdown fields. Picking the top level is no problem, but when trying to select a menu item from the dropdown list the problems start. The menu items are not possible to select one by one the normal way, they show up as a field where are items are included if trying to record the selection process, it is not possible to select only one. Identifying the selector manually is possible, but when using that code in an activity, no way, does not work. Nothing is being selected.

So, I do realize that I am probably doing a major mistake here somewhere. But UIPath is a relatively big forest to look for the mistake, so if anyone could point me in the right direction to look I would be grateful.


#2

Hi @wwls

It is really tricky to help you without a visual point of reference as to the look of that menu.

Could you provide a screenshot of how it behaves and maybe a screenshot of it being selected in UiExplorer?


#3

Here are three pics. The first show the dropdown closed, the second opened, and the third showing the UiExplorer output


#4

It is maybe a possibility that the problem is that UIPath do select the correct field, but that the application is not able to “Catch” the click so it is not being registered in the application.


#5

Here are three pics. The first show the dropdown closed, the second opened, and the third showing the UiExplorer output


#6

Just to clarify - have you tried using the Select activity? Normally it handles those types of menus really well.


#7

Yes, I have.


#8

I have basically tried everything I can think of myself, plus everything I could find here on the community. Nothing works. It seems like it “will work”, but it does not. What I mean is that it is possible to get to a point where the correct menu item is showing in the main box as if it was selected. And then it is possible to use f.ex. tab or enter to move on to the next field if using the recorder, or manually finish it. But when running the robot nothing has been selected.


#9

Hi @wwls

I have come across one such situation. I tried to click on the drop down button and directly click on the option that needs to be selected. You need two selectors in this case.
One to click the drop down button,
another to click on the option - this can be a dynamic selector updated at run time with the text to be selected.
Also, in your case you have a long list. So you might have to write a logic to keep moving down until the option is available. Once it is available, click on the option using the text.

Hope this helps.


#10

I can think of one more solution that worked for me with a certain menu. But this will only work if you can reliably scrap the text from the current selection.

It would work as follows:

  1. Create a DO WHILE loop and loop a simple sequence of get text activity (or get attribute if possible) and of sending a hotkey (tab or down arrow). Loop should end when the selection matches your desired one.

#11

Thank you very much for all tips. With a combination of your tips I was able to fix this problem. I know you are all busy so I am greatful for your time and effort!


#12

No problem, we’re all here to help. Could you let us know what finally worked?