How to run in unattended mode using image selector in click activity

Actually everything run in unattended mode, im stuck with only magnifying lens( image )click .
I also tried with CV activities its also working fine only in attended mode.

Can anybody give me a solution for this Magnifying lens click?

try to check the element of this button on the virtual machine,
could be the element is diffrent

have u try to add acnhor?
and use fuzzy selector and lower the threshold


Yes i added anchor as well and i selected (Croped) particular image only so i couldn’t get the fuzzy selector , its only mapped with image only.

hermn… this is weird,

have u checked the elemt when u try to run on virtual machine?

In CV activities before trying to click, Have you used CV element exists? Does that give you a True value for the Descriptor you have passed?

will CV activities run in unattendedmode ?

Please try to amend the Robot configuration as per the below

Yes, but that should be used in exceptional cases where the normal activities fail to identify the selector. (Resolution changes will effect the CV activities)
Try using Find Element in classic or check app state in Modern activities to see if your selector is valid in Unattended mode.

How do i go there?

Could you share the unattended mode Robot Logs for this error

1 Go to Tenant
2 go to Users
3 select the : for your robot
4 Robot Setting

When i run in unattendedmode, i got this error for " Click HoldClaimsMagnifyingLens: Cannot bring the target application in foreground because the Windows session is locked."

So this error only occurs for this particular magnifying icon click & every other click activity is working fine ?
Have you tried using “Simulate Click” , Also I hope you have checked the settings mentioned here

Yes i used Simulate click and Window messages as well

Yes this error only occurs for that particular magnifying icon click activity

Hello @divyanancyit

Can you please confirm the robot is installed as service mode in VM?


Yes,we are running unattended bot as service mode in vm.

When i tried with click activity in object repo, i got this error for Clicking magnifying lens
" Exception Message : Could not find the user-interface (UI) element for this action. Possible solutions: • Ensure application is opened and the UI element is visible on the screen at execution time • Edit the Target of the UI activity and use Validation to debug the issue. • If needed, re-indicate the element as its properties might have changed • Use “Check state” activity to check the application state before executing the action • Increase the “Delay before” value to allow time to the application to render entirely and become responsive "

How to run Computer Vision activities in unattended mode?

Can anybody knows how to fix it as i am unable to run that unattended mode and its working fine in attended mode? Please suggest me.