How to run a project without ui studio? plz help. am a fresher

I want to run the program in another system where they dont have uipath studio? how do i run the project there ? is that possible without installing uipath studio in their system( its an internal service . i dont need cloud). plz help.

@Nandhini_Vishnu
It is not possible to run a Uipath project on a system without Uipath. You can use the Community version there.

1 Like

thanks so much for ur reply . Community edition or Enterprise edition ? i dont want my client to install uistudio or assistant as it occupies space in their machine.

Also one more query , is it possible to create a git hub and they run the project from there.plz some one help

@Nandhini_Vishnu Community Edition is Free whereas Enterprise is paid after 60 days trial.

1 Like

Tough, you need to install UiPath Assistant at the bare minimum. You can skip Studio.
You need to take up space on their machine, the robots are not made into compiled executables, the need a program to run them in.

1 Like

thanks a ton . can i install only UI Assistant in the Community edition ? or is it possible only in the enterprise edition.

Hello,

You can run the project without studio. You just need to install Assistant in that particular machine and connect to the orchestrator. After that, you will be able to see all the processes published in orchestrator in the UiPath assistant. I think this is possible only with Enterprise edition, not community.

Thanks!
Athira

1 Like

thanks a ton .

1 Like

Hello @Nandhini_Vishnu

If you want to execute the project without using the studio you can do it in diffferent ways…

  1. Using the orchestrator- So you have to connect the uipath assistant to the orchestrator and you can publish the project from studio to orchestrator. Then run the process from orchestrator.

  2. Using UiPATH Assistant: once the process gets downloaded to assistant, you can execute from the assistant

  3. using the robot- In the uipath installed path, you will be able to find the robot.exe,
    so by passing the .xaml file to the robot.exe it will start executing

“C:\Program Files (x86)\UiPath Studio\UiRobot.exe”
/file:“C:\Users\UserName\Documents\UiPath\UiPath\Robot\Main.xaml”

2 Likes

i am unable to find robot.exe file .

@Nandhini_Vishnu

can you search it inside C:\Program Files (x86)\UiPath Studio

You can also refer to the below post.

1 Like

could not find in localappdata and also in program data.
tried in this location as well.
C:\Program Files (x86)\UiPath [Studio]…
but i could not find

It should be there somewhere in the c drive. Can you do one thing, search for uipath assistant in the start,->right click and open the location->from the location mostly it will show the shortcut icon->right click and select open the location.

1 Like

thanks a ton. god bless u . finally i got it .

1 Like

Good to hear that :slightly_smiling_face:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.