How to resolve these Excel Application Scope errors?

Hi, guys.

I ran into the following 2 errors when I run the robot using Excel Application Scope sometimes. I could’t find why these error occured, Is there anyone know how to solve these errors? Thank you!

※Those are my studio and excel version info:
image 64bit

  1. Excel Application Scope: Unable to cast COM object of type ‘System.__ComObject’ to interface type ‘System.Runtime.InteropServices.ComTypes.IConnectionPointContainer’. This operation failed because the QueryInterface call on the COM component for the interface with IID ‘{B196B284-BAB4-101A-B69C-00AA00341D07}’ failed due to the following error: 要求されたオブジェクトが存在しません。 (Exception from HRESULT: 0x80010114).

  2. 【Message】Error opening workbook. Make sure Excel is installed. 【Source】Excel Application Scope


For now, can you try Repair Tool for Microsoft Office?


1 Like

Hi @111962 ,

If you are able to open the Excel manually it should work with UiPath also. You can try to “Repair Tool for Microsoft Office” which will help to resolve the glitches in the intergration.

Else you can try to use the Workbook activity instead of the Excel activities.

1 Like

thank you for your reply. I tried repair tool for Microsoft Office. it seems doesn’t work.
I run the same robot in different PC, It worked well in my local desktop environment.
I think maybe there’s some wrong happened in Excel. I’ll tried to figure out how to resolve this.

Thank you for your reply.
I was able to resolve this error by referring to the following site.

Open the excel application , click ;

  1. File
  2. Options
  3. Add-ins
    Click the drop-down options next to “manage:” and select “COM Add-ins”, then click “GO”
  4. Untick/deselect “UiPath.Intergration.ExcelAddin”, click “OK”, close excel and run the bot again.
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.