How to resolve the error Could not find a part of the path C:\Users\...\UiPath\app-19.10.0-beta0185\Profiles

Last time (a couple of days back) when I started UiPath, I was aware UiPath Studio was updgraded to Version 2019.10.0-beta.155

version

Now since today morning while trying to open UiPath Studio I am facing the error as:

Could not find a part of the path

CouldNot

My questions are:

  1. Why would UiPath autoupdate to a beta release, as historically beta releases are good for testing of release candidates but not for production?

  2. Are beta releases well tested before pushing for Auto-update?

  3. What are the measures we can take to stop the Auto-update of UiPath studio?

@debanjan

Go to Help section in Uipath studio and select Stable radio button instead of Preview and then uipath studio won’t update automatically.

2 Likes

Thanks @lakshman While I face this error I can’t even open the UiPath Studio. Can you suggest me a way out? Additionally, can you help me with the other two points as well?

1 Like

@debanjan
You could try manually creating the folders in that path. Otherwise an uninstall and reinstall would probably be work.

As to your points above:

  1. It auto-updated because the preview channel was selected.
  2. They’re beta releases, so they aren’t going to be as thoroughly tested as the releases on the stable channel.
  3. None, for community edition. If you have enterprise edition it won’t update until you update it, but community edition updates automatically to use the latest release on whichever channel you select.
1 Like

Thanks @DanielMitchell That sums up quite everything.

So can we conclude that users using the UiPath through the preview channel will have to uninstall and reinstall UiPath on each beta push?

Doesn’t looks like a viable option to me !

@debanjan
Not at all, you only need to uninstall and reinstall if there is an issue with the update, which should happen very infrequently.

1 Like

Agree @DanielMitchell Happened to me for the first time.

I still feel Uipath Studio Team can easily fix up this issue. Thanks !!!

1 Like

Hi @debanjan

I think the issue comes from the fact that the update happens in the background and could be that it is being done the moment you close your Studio (which then renders it incomplete, in your case not creating the folder yet).

I believe there are already plans to address that.

Until then, the auto-update seems to work really well, as long as you let it finish.
The easiest (and currently the only way) is to check the %userprofile%\AppData\Local\UiPath folder to see if there is no more ‘movement’ happening.

3 Likes

@loginerror You nailed it. As I face the UiPath Studio opening error for Version 2019.10.0-beta.185

It’s clear the directory of app-19.10.0-beta0185 looks incomplete:

185Directory

when compared with the directory of app-19.10.0-beta0155

So, can we conclude in these cases we have to reinstall UiPath Studio ?

Actually, you can try to first delete the incomplete directory, as well as this one:
%userprofile%\AppData\Local\UiPath\packages

Then you should be able to launch the previous version and let Studio auto-update.

3 Likes

I don’t have any words how to thank @loginerror albeit a master.

Deleting the corrupted profile worked.

@DanielMitchell Thanks again for your valuable time, suggestion and support when I needed the most.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.