How To Resolve Excel application scope Error using MS 2010?

studio

#1

Hi Team,

Facing issue with Excel Application scope using MS 2010 and it is working fine in MS office 2013.

Exception Details:

WF1_2D SHARE has thrown an exception

Source: Excel application scope

Message: Exception from HRESULT: 0x800A03EC

Exception Type: ExcelException

UiPath.Excel.ExcelException: Exception from HRESULT: 0x800A03EC —> System.Runtime.InteropServices.COMException: Exception from HRESULT: 0x800A03EC
at Microsoft.Office.Interop.Excel.Workbooks.Open(String Filename, Object UpdateLinks, Object ReadOnly, Object Format, Object Password, Object WriteResPassword, Object IgnoreReadOnlyRecommended, Object Origin, Object Delimiter, Object Editable, Object Notify, Object Converter, Object AddToMru, Object Local, Object CorruptLoad)
at UiPath.Excel.WorkbookApplication…ctor(String workbookPath, String password, Boolean visible, Boolean createNew)
— End of inner exception stack trace —
at UiPath.Excel.WorkbookApplication…ctor(String workbookPath, String password, Boolean visible, Boolean createNew)
at UiPath.Excel.Activities.ExcelApplicationScope.Execute(NativeActivityContext context)
at System.Activities.NativeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Regards

Aabhas Bhardwaj


#2

Hi @sunnyabhash

Seems to be a compatibility issue. From my research on the error, this may occur because of a large file size.
Also, found some steps that may help:


#3

Thanks Ovi… But i already tried it and did not get sol. for this issue. Is there any other way around to solve this .

Regards

Aabhas Bhardwaj


#4

Hi ,

Can you check below link
https://social.msdn.microsoft.com/Forums/vstudio/en-US/47c602c1-41e5-42ee-a845-a21889c3a75d/working-with-excel-interop-2010-exception-from-hresult-0x800a03ec?forum=vsto

Thanks
Sanya


#5

Thanks Sanya for Link but i am just executing macro under excel application scope in UI path . This is working in 2016.2.6379 and i am facing this issue in 2017.1.6435 build. The BOT is earlier working in trial version and when i moved the code in licensed version i am facing this issue.

Regards

Abhash Bhardwaj


#6

same problem here all of a sudden


#7

@qateam


#8

can we have more details? it would be perfect if you can share the workflow and the text excel file
if not, tell us at least what activity is throwing this error, and on what kind of excel file.


#9

same error i was getting after new version of UIPath.
for me after saving file again i.e. SaveAs worked for me.


#10

This error generally comes when your excel file is corrupted. Try to open the file manually and save it again, This will work fine after that.


#11

I am also facing the same error after updating to latest version. I think there is some issue in latest update as the new feature auto save is here. I think after running macro when uipath saving file , the file is getting corrupt.


#12

Hi,
i am also getting the same issue while copying data from one excel and past into another.

Did anyone find any solution for above issue ?