How to pass a Data Scraping Variable (Out) in other Variable

datatable
uiautomation
activities
studio

#1


I try to import a variable (containing information about a table that has been scraped through Data Scraped) from another workflow and assign it to another variable of type DataRow [] … but I get an error message (Systrm .NullRefereceException : Object reference not set to an instance of an object).

someone can help me kindly, I would be very grateful.


#2

Inside the invoked workflow you must setup your datascrape to output to an Argument (not variable) (arguments are listed right next to variables in the bottom of your screenshot)with the direction out. then save the workflow. Then in your main sequence click the import button you have highlighted. You should see the Argument pre-listed. In the rightmost column put your DataTableVariable.


#3

I tried but the error insists @tsl


#4

click on import arguements and share the screenshot @momi_fede


#5

The error tells you that your variable is empty. This can happen in one of to ways: Either your argument import is not setup correctly, or your datascrape is not outputting to the argument.

The way it works is 1) Datascrape sets datatable argument -> 2) Import sets variable to argument - 3) you try to select from variable.
Either 1 or 2 is wrong. if you could post a screenshot of the properties windows of the screenscrape and a screenshot of the import window i could tell you more.


#6

I solved the problem … it was just a syntax problem. thanks for the help!!
but I have to ask you one last favor … I do not understand why the process keeps closing … can someone help me? ReFrameWork-master.zip (3.1 MB)


#7

Could you specify more? It seems you are using te RE Framewok. It should close when there are no more queue items to process.


#8

the system collapses me because of an error on GetTransactionItem and I can not understand what kind of error it is


#9

ok. i opened the “get transaction item” flow. It does not get a trasaction item. If you doubleclick the arrow labaleled "no data"in the main workflow - general business process, you will see it triggered by “TransactionItem Is Nothing”. Thus your workflow will always stop.
Are you using RE framework without the orchestrator queue?


#10

yes @tsl


#11

it may be that the error is given by the fact that I have passed the second point? (I skipped it because I could not figure out what exactly he wanted to understand) @tsl


#12

I only followed the instructions in the PDF file



#13

Ahh. I didn’t see you were doing the academy - my bad. Anyway your problem is in the import of arguments.

Look at the attached screendump. in the invoke activity you don’t set workitems to anything. You also have validation errors in your get transaction workflow.


#14

I’m sorry I did not grasp what you mean @tsl


#15

The above image is what appears when you click import where you invoke the get transaction items workflow. You do not give workitems a value (the last row in the screenshot). thus your workflow cannot process anything.


#16

I tried now the flow works.
Thank you very much for your help … I hope I can ask you for more advice later


#17

No problem. See you around :slight_smile:


#18


could you tell me why this error generates me? my goal is to select a state from a list that is in the drop-down
box @tsl
Work_Items_Update.xaml (9.7 KB)


#19

Try the click activity instead for selected new status


#20

I’ve already tried. the only problem is that the selected item is passed through a variable