How to make an orchestrator API authentication for a new account

Error shown is “Invalid credentials”, but I am using the same email and password of gmail account.

{
“tenancyName”: “Robo”,
“userNameOrEmailAddress”: “”,
“password”: “”
}

I also tried creating new password by clicking on Forgot password . But still not able to proceed with orchestrator api.

The authentication steps are changed now as the orchestrator is moved to cloud @Arun_s

Go through this link, explained step by step to authenticate

@HareeshMR I am using https://docs.uipath.com/orchestrator/v2019/reference#authenticating. not able to login

You need to use these steps to authenticate @Arun_s

https://docs.uipath.com/orchestrator/v2019/reference#consuming-cloud-api

1 Like

I am getting error like this …

{

"error": "access_denied",

"error_description": "Unauthorized"

}

@HareeshMR That was a fix.

Are you able to authenticate using API @Arun_s?

@HareeshMR Yes.

Hi Hareesh,
i followed your url but still not able to authenticate the ui path api.
can you please help?
Regards,
manish

@Manish_Jawla

Getting authenticated is complex if you are just reading the official documents.

I have a blog post that explains it in a little more detail:

http://dealetech.com/the-definitive-guide-to-uipath-cloud-orchestrator-2019-09-rest-api-authentication/

What error or issue are you having with Authentication?

– Michael.

1 Like

Hi mjdeale,

Now, i am able to autheticate and get in response:
{
“access_token”: “[access token]”,
“id_token”: “[id token]”,
“scope”: “openid profile email offline_access”,
“expires_in”: 86400,
“token_type”: “Bearer”
}
access token and Id token, but to get use the further api like get environment detail which token i must use with bearer +. ?

Hi Hareesh,
thanks for sharing that link but now i want to trigger orchestration processes through external system using API. Can you help me achieving that.
for eg: i have a processes which is managed by some robot and working fine with ui path, but i want to achieve the same behavior through some external system using api. Can we do that?

1 Like

To retrieve your AccountLogicalName and ServiceLogicalName you must use the IdToken as the bearer token.

To make REST API requests you use the Access token as the bearer token.

Remember the Access Token expires in 24 hours after issued, so either refresh it when it expires, or grab a new one (using the refresh token) every time you start a new session.

Also, there are a number of headers that you must get correct in addition to the Authorization header.

You need Content-Type, X-UIPATH-FolderPath and X-UIPATH-TenantName.

Hi,
i am trying access the below api with id token but getting error

https://platform.uipath.com/cloudrpa/api/getAccountsForUser

{“timestamp”:“08-11-2019 10:18:15”,“errorMessage”:“Full authentication is required to access this resource”,“debugMessage”:null,“errorCode”:9024,“subErrors”:null}

@Manish_Jawla

I was out of town over the weekend. Did you get this all working?

– M

Hi,
Now everything is working :).

You got it working @Manish_Jawla?

yes :slight_smile:

it is not working for me as well. The same code was working before now it is showing
{
“message”: “Invalid credentials, failed to login.”,
“errorCode”: 1000,
“resourceIds”: null
}
whereas i am entering the same credentials as I am using for web login

Can you please share the work around you did so far to this issue so that the people on the forum with the same issue will have a look at the solution @Manish_Jawla