How to implement with orchestrator?


I’m able to use computer vision in Studio and run the process. But when I try to publish the project to orchestrator and let one of my robots conduct the job, they will fail instantly. I realized the package was missing, so I added the .nupkg manually to the Orchestrator library. This did not resolve the issue.

After that, I tried to add the nuget beta feed to the nuget.config on each robot but it did not resolve the issue either.

What could I do to get this to work beside in Studio?

I don’t know if it is yet support. This is a beta release of the computer activities

Hmm, we’ll look into it

Could you try clearing the nuget cache on the robots? The problem is most likely related to getting the package on the robots.
@ovi is there a link to how to do that?

@celfa, is there a specific error message the robots generate?

@Cosin, I’ve no clue how to clear the nuget cache?

The error message from Orchestrator:

Thx! we’ll get back to you shortly

Hi @Cosin,

I’m experiencing a simular issue when deploying attended bots which use CV, (so without Orchestrator).
My error message looks like this:

I’ve tried:

  • Reinstalling Studio & Robot
  • Removing Uipath entirely then reinstalling
  • Copying packages from studio to robot

Hopefully this info helps.



I tried to update to the new alpha version and got the following error message form Orchestrator:

* Cannot create unknown type '{}OpenApplication'.

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
System.Xaml.XamlObjectWriterException: Cannot create unknown type '{}OpenApplication'.
at System.Xaml.XamlObjectWriter.WriteStartObject(XamlType xamlType)
at System.Xaml.XamlWriter.WriteNode(XamlReader reader)
at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter)
at System.Activities.XamlIntegration.FuncFactory`1.Evaluate()
at System.Activities.DynamicActivity.OnInternalCacheMetadata(Boolean createEmptyBindings)
at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList`1& validationErrors)
at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack`1& activitiesRemaining, ActivityCallStack parentChain, IList`1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback)
at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList`1& validationErrors)
at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList`1& validationErrors)
at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.WorkflowApplication.EnsureInitialized()
at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push)
at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout)
at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state)
at UiPath.Executor.RobotRunner.RunWorkflow() in D:\a\1\s\Robot\UiPath.Executor\RobotRunner.cs:line 301

No, alpha versions should be avoided, unless specifically instructed.

You should try clearing the cache on affected machines/robots and install latest beta:
Delete .nuget folder from your local profile.
It is located under C:\Users{UserName}.nuget\packages\

you should delete/clean these folders:

1 Like

Thank you @Cosin now it works :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.