How To Get tableRow attribute in ‘Get Attribute’ Activity?

Hi All,

I’m trying to get the tableRow attribute using ‘Get Attribute’ activity. I want to pass a variable as the ‘aaname’ selector. But since the target was a Text Box, it doesn’t have that ‘aaname’ selector.

So i’m trying to get the tableRow attribute from a Text Box that contains a text from a variable that i’ve made.

Picture Below is the cell that I want to get the TableRow attribute:

Here I provide the UI Explorer of the element from Get Attribute activity:

As We can see down below, since the element was a Text Box, the aaname showed blank instead of ‘2222222’ as shown on the web

In a simple way,
i’m trying to get the tableRow attribute from a Text Box that contains a text ‘2222222’

Any Ideas? … any help would be appreciated

Hi,

Can you try to change to Access Accessibility in UI Framework, as the following.

Text of input box might be identified as “text” attribute in selector.

Regards,

Hi Yoichi, Thx for your response,

Unfortunately, changing UI Framework to Active Accessibility still doesn’t work for me … I already enable the Type attribute as well but still the same


The result shows it still choose the wrong cell,
What I want is the selector to choose a specific cell with the name ‘222222’.

Usually I use like: aaname=‘2222222’
But in this case it has no aaname attribute …

How do I choose the correct cell that has a specific text on it?

Hi,

The following is not vert efficient way, but will work. Can you try this?

Regards,

Have you tried ‘text’ instead of ‘aaname’ in Get attribute activity.

Give it a try by using Inspect Element, you can get all the UI Element properties over there!