How to get CredentialAsset from UiPathStudio(Not Orchestrator) using the GetRobotCredential?

Hi everyone,
I am currently studying in the Orchestrator Basic course at UiPathAcademy.

After setting up a Credential asset in Orchestrator, I use GetRobotCredential in UiPathStudio, but I get the following error
(If I run the publish from UiPathStudio and then run it from Orchestrator, I can successfully get the contents of the CredentialAsset.)


資格情報を取得: この名前のアセットを見つけることができませんでした。 Error code: 1002
This means "Could not find an asset with this name. Error code: 1002

UiPath.Core.Activities.OrchestratorHttpException: この名前のアセットを見つけることができませんでした。 Error code: 1002
This is a "
UiPath.Core.Activities.OrchestratorHttpException: Could not find an asset with this name. Error code: 1002".

How can I successfully run GetRobotCredential in UiPathStudio?

The information in the following link did not solve the problem.

It seems that the same method cannot be solved because the version of UiPathAssistant (Robot) is different.
UIPathStudio & UiPathAssistant -21.4.4

Kind regards.
Thanks.

Hi

Welcome to uipath forum

If you want to any asset be it credentials or text the bot has to be connected to orchestrator
And if the orchestrator is connected we can retrieve it in studio
That you were getting the asset when connected with orchestrator

Here you go on managing assets

Cheers @tspath1900

Thanks for the replies. It is very helpful.

When I ran it from UiPathAssistant, I was able to get the CredentialAsset without any problem. I think the robot is able to connect to Orchestrator.
Then I checked the link you gave me and checked the GetRobotCredential property on UiPathStudio.

I am using the UiPathAcademy sample zip file without any modification and I am able to reference the CredentialAsset when I run it from Orchestrator.
So I don’t think there is a problem with the GetRobotCredential configuration.
I was able to do Publish the file without any problem.

I don’t know what settings are needed for UiPathStudio to connect to the Asset on Orchestrator when I do “Debug File” - “Run” in UiPathStudio.

Run in Orchestrator - OK
Run in UIPathAssistant - OK
Debug run in UiPathStudio - Fail

I am studying in order as per the academy video, some settings I did may be missing or wrong. I will check again.

Thanks.

In studio we can check whether robot is connected or not at the right bottom of the screen
Here
Processing: IMG_9345.MOV…

Make sure it is connected or click on refresh button

And then give a try from studio

@tspath1900

Thanks to your suggestion, I solved the problem.

Here is how it was resolved.

I found the same icon at the bottom of the screen. Its tooltip had only “Refresh” and I pressed it, but the result of execution was the same, fail.

Then, to the right of it, there is a list box (“Default” is shown in your picture).
I noticed that this matches the “MyFolders” in Orchestrator.

I was running it from the Attended folder in Orchestrator.
In UiPathStudio, I was running it from the folder with my account name.

When I changed to the Attended folder, I was able to get the CredentialAsset in UiPathStudio without any problem.

So when UiPathStudio connects to Orchestrator, it needs to match this list box?

I may have been doing something different from the UiPathAcademy procedure. Because there was no procedure to change this list box.

Thanks for giving me the information.

1 Like

Superb @tspath1900

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.