How to fix MailMessage components that cannot evaluate at current context?

I am retrieving messages from an Exchange Server, then looping through with a For Each to find the right message. This works in my Load queue, but not now while going to loop through to find the referenced email in the Process Cases.

The MailMessage is populated with all of the information, but the From/Sender/ReplyTo/To/CC/BCC/etc. are not showing “Cannot evaluate ‘mail.From’ at current context.”

Any help would be appreciated.

Studio: 2020.10.4
Mail Activities: v1.9.5

Edit: This is a project that was converted to the Modern Design Experience. Is this a bug?
Edit2: Just tested three scenarios: start with a Classic project, Start with a Classic project and convert to Modern, Start with a Modern Project. Only the first scenario worked. Something is wrong with Modern and the MailMessage object.
Edit3: Tested reverting back to Classic as well as rebuilding, but this did not work. Could be an issue in the version, as the Classic project was built prior to 2020.10.4
Final Edit: This worked itself out, maybe closing and reopening. Not 100% sure.

During debug - what happens if you print those values in “Immediate”?

Same Message. Cannot evaluate ’ mail.From’ at current context.