How to Fix Bad IL Format error while publishing document understanding project

Hi Team,

I have created the Document Understanding process using the Document understanding template in UiPath studio. When i publish this process i get the error message as shown below while loading dependencies. Its reporting error for in total 18 files

Bad IL format. The format of the file .nuget\packages\UiPath.cefsharpbundle.netcore\1.9.0\lib/net6.0-windows7.0/Ijwhost.dll’ is invalid.

Bad IL format. The format of the file .nuget\packages\UiPath.emgucvbundle\1.1.0\lib/net5.0/concrt140.dll is invalid.

It still goes ahead with package creation and creates the package.

I have tried updating the dependencies to the latest available version but still the same issue
image

Please suggest how to resolve this issue

Hello @Benajir_Khan1

Do you get this error when you try to debug or validate the project in Studio?

Does it only happen when you try to publish to Orchestrator?

Thanks
Lahiru

The project shows some compilation errors that appear when it is built, but disappear when it is debugged or run. The errors also show up when the process is published to orchestrator during loading dependencies, but the package is still created and can be executed in both attended and unattended mode. I am not sure if these errors will affect the document understanding process in any way .
Thus checking here if if there is any solution of this problem

Hello @Benajir_Khan1

I have seen this happening too… So far I have not seen any impact on the process execution. Probably this is something internal.

Thanks
Lahiru

Did anyone get a resolution to this? I am getting the same issue but won’t publish to orchestrator for me. Project works within studio fully.