How to filter WI5 type with open status data in assignment 1

Hello Everyone,

I trying very hard to complete the assessment , i am failing every time i do :frowning:

I have reached the stage till we extract work items from acme system .
Next step is to filter the data WI5 type with open status

Open the Main workflow and expand the Init state by double clicking it.
Add a new sequence after the Invoke KillAllProcesses activity to read the input transactions data table.
o Inside this sequence, invoke four of the previously created workflows, as follows:
:black_small_square: System1 Login
System1 Navigate to Work Item
:black_small_square: System1 Extract Work Item Data Table
:black_small_square: System1 Close
o Import and bind arguments where necessary.
o From the list of work items, extract only the items needed in the current process - those of the WI5 type, with the status set to “Open”.

I haved added Assign activity below these 4 invoked workflows

WIList = dt_WIs.Select(“Type=‘WI5’ AND Status='Open '”)

When I run the main file , i get an error saying
Object reference not set to an instance of an object - for assign activity .

Please help

Please make sure that

dt_WIs is in Data.Table format; and
WIList is in Array of rows format.

1 Like

And for
WIList = dt_WIs.Select(“Type=‘WI5’ AND Status='Open '”)

Please make sure that after open, it shouldn’t be a Space.

1 Like

I had given space after open . and variables are set as you said

NO SPACE AFTER OPEN

In one of updates in forum , it was mentioned that we need to give space . Thats the reason I had given a space . now I removed space and still i get the same error .

Mind uploading to whole workflow?

The whole workflow Mr Kavsanu if you would kindly

Advanced level Training.zip (3.4 MB)

I can’t seem to run your workflow. Have you modified the path of your invoked workflows?

image

The path should look sth like this instead:

image

yes i modified as i had to take the workflow from my desktop

My workflow is getting stuck at Assign activity only … which i have used in init state . i have not yet reached get transaction data stage


All those invoked workflows should be in the same folder as the main workflow.

you mean to say all the workflow files that is there in Framework folder , System1 folder & Sha online folder should be placed where main workflow is present

I think you have the wrong workflow on the extract data table. We should “out” the datatable instead of setting up the variable.

image

If i delete the variable , and just create an argument , what should i put in the property - Output DataTable of extracted structured data table container

Ya, it should be the argument and invoke workflow should include such argument as well

I did that . I am not getting the error now . But i want to know how to check if the data is filtered.
I think i found where I am stuck . In get trasaction data ,

I have used Assign activity in Then section

out_TransactionID=out_TransactionItem(“WIID”).ToString
There is below error

Error: Option strict on disallows late binding

Could you please help me on this

Hi @kavsanu - Try to change the try with changing the type of the out argument(out_TransactionID) to ‘Srting’.

Thanks,

Arguments Out_TransactionId and Out_Transactionitem is of type string only. I changed the type to Queueitem for Transaction item . Now i get error in both the assign activity .
Attached get transaction data xaml file . Please someone have a look and help me out there .

GetTransactionData.xaml (8.9 KB)

Thank you