How to dowload PDF from Web Interface


I am trying to download multiple PDF files from differing URLs and save them to .xlsx (I know that I will have to use some type of converter for this?). However, I am trying to determine the “best” way of doing so.

Is my only option to navigate to URL and then Insert Hotkey command to ‘Save As’? Or is there another way?

Also, has anyone attempted to use PDF extraction and then convert to .xlsx for manipulation?

To download an PDF from an URL you can simply use HTTP Request activity with the URL set to EndPoint property and the local file name where you want to save it set in ResourcePath property.
The HTTP Request activity can be found in UiPath.Web.Activities pack.

Credits: @Lavinia

you can extract into a datatable and load it into excel.

Read PDF Text
Read PDF With OCR (image pdf)


Thank you vvaidya!

However, I am receiving this messy response.

My parameters are:

End Point =

Request Method = GET

Accept Response As; Any

4349 0 obj
<</Linearized 1/L 124670/O 4351/E 6516/N 18/T 124059/H [ 480 212]>>

4361 0 obj
<</DecodeParms<</Columns 4/Predictor 12>>/Filter/FlateDecode/ID[<0513953E4A15E24DB1EEBD495192631C>]/Index[4349 22]/Info 4348 0 R/Length 67/Prev 124060/Root 4350 0 R/Size 4371/Type/XRef/W[1 2 1]>>stream
h�bbdb`Z$�`�!�`�b��X� ���a& �N �Ҋ��Q�a�b$@����’@�

Any idea why this is happening?

just tried your url, works fine.below is my property pane


Thanks so much vvaidya!

You’re a lifesaver :wink:


Hi every one

I kind of stumbled onto the a version of the same problem. I tried to download a pdf from invoice-generator webpage. However when using the HTTP Request with EndPpoint property the URL and ResourcePath property the local file name a (.pdf), I get a pdf that has an error message saying that the file has been damaged or type is not supported.

Maybe there is a property wrong?

@vvaidya I am also facing the same problem after download completed, it showing error PDF%20Opening%20Issue

Please help me to resolve this issue

1 Like

Is it fixed?

Same problem, someone got a fix?

Can you upload the file that is actually downloaded it? What happens if you open it with a text editor as a .txt file type?