How to detect the "Tick" mark in the drop down list

I have a drop down list which is basically the numbers from 1 to 9 (see the image enclosed) in the desktop application.
There are 2 tasks:

  1. Detect which of the items is currently “ticked” with the tick mark. The challenge is that this “Tick” is not detected as an UI element. The UI Path grabs the whole item in the drop down list (thei “Tick” and the number). I tried to use “Find image” but this did not work either. The image is found OK (I checked it with the “Image exists” activity) however the UI Element which is an output of the Find Image activity is incorrect - it is the main application window. I don’t know how to make “Find image” return the correct UI element.
  2. Click on the required number in the drop down list. Select item doesn’t work at all (says “not supported”). The selector of the item in the drop down list cannot be made dynamic as it doesn’t contain any variable components. Moreover, I cannot open it in the UI Explorer. Is there any wat to get around it ?


If uipath grabs the whole item, what is the output?
Can you use this to identify the tick?
Could you use data scraping on this element to retrieve the necessary data?

Once you have this in a datatable you can filter the wanted line.

If the element is not supported, you can always try to send hotkeys to the proper element. mostly a space is use to selected an item. with tab you can go from one item to another



Hi Tom
The output is just the text “1”, “2”, …, depending on where I clicked. Moreover, the selector doesn’t have any variable component so there is no way to make it dynamic.
Data scrapping doesn’t work at all because this is a windows application, and this method is for the browser based activities only.
To send the Hotkey I should indicate the element. To indicate the proper element the selector should be dynamic which is not possible as it doesn’t have any variable components.

Hey @MichaelK, data scraping should work on desktop applications just fine. We use the data scraping activity to get table text from an old windows application that we use.

Hi @DanielMitchell, possibly it works for some desktop applicaitons however when I try to use it mine I’ve got this message from UI Path: image

What actually happens from you try to identify the element using UiExplorer? There may be some attributes for the elements that may indicate the selection.

Rammohan B.

Hi @Rammohan91

When I click the UI Explorer in the UI Studio and then select the element the error message comes up as below:
Please note, to select the element I need to click F2 to pause, then click the menu item to get the drop down list, and only after that I can select the element.

Have you tried get attribute “check”?

Hi @Smith93

Yes, I did try it and it works when I select the “ticked” UI element the “checked” is True. However the problem is that I can’t make the selector dynamic to find which element is “ticked”.

Sorry for late response, did you figure this out?

If not, can you send me the selector of the checkbox?

Thank you @Smith93. I resolved it a while ago.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.