How to detect a text in SAP


#1

Hi guys I have an extrange problem. I made a robot that is able to read a text in SAP. The problem becomes when this robot is launched in unattended mode, in this way, the robot is unable to find that text.

Why could be the reason ?? I tried to change my desktop resolution to the same resolution that the disatended robot use, but it still not working.

I guess that the unattended Robot should work like the normal robot is working, but thats not happening

Any other idea?

Thank you guys, my best regards


#3

More than that, the reason of the error that UiPath give to me is: " couldn’t click in text ‘Dat.org.’ ". That’s the text which the robot has to click, and work perfectly unless I launch it unattended. So, thinking in that error, we can suposse that the robot arrives to that screen, but fails in click the text of the image.

Thank you very much.

Regards,

Pablo


#4

Hello!
did you resolve the issue?
I have the same problem now and trying to find any sollution.


#5

Hi @Alexey,

Yes I have solved the problem. It was a resolution issue. When an unattended robot is launched through VM, the resolution could be limited to 800x600 (at least that was the resolution that VM used). So, to solve the problem, I used “launch interactive workflow” activity, in which you can put the exact resolution that you want the robot must use in the process.

When you launch this workflow, you have to check the loginToConsole propertie. If you don’t, the machine wont run at the resolution that you have put in the screen resolution propertie. If you run it in a VM, it will kick you out from the VM when you launch it, thats normal, but you may have log in again in the VM to check if its going great.

I hope it can help you.

Bests,
Pablo