How to Create custom Activity with X86 CPU

Hi Team,

Can someone help me, I am creating a custom activity using Active solution platform as X86 mode in visual studio 2019.(Not able to select ALL CPU in Visual studio due to some constraints).

I am able to create a NuGet package, but after installing the activity in UiPath 2019.8.0.
Custom activity is not visible in UiPath Activity window.

Is there any dependency that the solution always has All CPU settings.

Hi @Ankit_Genpact

It might be something different. Please see the guide here:

Maybe this bit is important?

Important!

The NuGet Package Id field must contain the keyword “Activities” to appear in the Manage Packages window, in Studio.

1 Like

Thank you .

The above work for “All CPU” projects, but my requirement is of X64 or X86 bit solution.

Is this issue resolved?
I’m also facing the same issue

I’m not able to reproduce, but would guess this is a problem of building a 64-bit package and installing on a 32-bit machine.

Just curious–what’s the restriction that prevents you from using All CPU? This setting creates a package that supports both 64- and 32-bit machines.

When I compile my custom activity with 64bit, it is not visible in UiPath. I have one library which works on 64bit(Keras.NET for win64).
If i have tried with x86, then activity is visible but Keras.Net throws exception. “BadImageFormatException”

It sounds like you’re working on a 32-bit machine. It can’t read the 64-bit package and it can’t use the 64-bit library, but it can read the 32-bit package.
I’d suggest finding a library that supports both or work on a 64-bit machine.

1 Like

Thanks, DeanMauro.

I will do the same.

1 Like