How to create a file.bat

@RajeshT You have to use path robot instead of studio.

Hi @Manjuts90 Manju,

Thank you for the response.

Even it doesn’t launch the Uipath if i use robot instead of studio.
Please help if am doing any mistake.
\file: “C:\Users\CL100126\AppData\Local\UiPath\PMACSExecutableLogsValidation.xaml”


@RajeshT Try below path


instead of


If above option didn’t work try below options also.

Check also other options -file or -f instead of \file

Hi @Manjuts90 ,

Can you check my Installation done correctly,seems i dont see robot.exe in my folder.
Above mentioned doesn’t worked for me.


@RajeshT Once uipath studio gets updated and folder is created for that version automatically.

Please check app-19.8.0 folder

try this one. its working for me.

“C:\Users\CL100126\AppData\Local\UiPath\UiPath.Robot.exe” -f “C:\Users\CL100126\AppData\Local\UiPath\PMACSExecutableLogsValidation.xaml”

I have given pause in the bat file and checked and found the below errors:
@ryzuke0515 @Manjuts90

If i give below format ,the studio is launching but getting the below error:


@ryzuke0515 @Manjuts90 @Rammohan91

The below code working fine
Thank you for your inputs @Manjuts90 @ryzuke0515
start “” “C:\Users\CL100126\AppData\Local\UiPath\app-19.8.0\UiRobot.exe” -file “C:\Users\CL100126\Documents\UiPath\PMACS UAT Validation\Main.xaml”

1 Like

Please can you tell where is the UiRobot.exe located? As far as I know, when we design a UiPath process, it creates two files of extension .json and .xaml. If .exe is also created then where is that located?

Thanks in advance!

There is no exe created. You launch the process like this


It’s ok I found the file. It was actually the UiRobot.exe which I found in C:\Users\Your-user\AppData\Local\UiPath\app-19.3.0\UiRobot.exe.

1 Like

You are correct @Hassan_Ali

Here I have a problem. To create batch file I used the syntax:
start “” /min “C:\Users\my-pc\AppData\Local\UiPath\app-19.9.2\UiRobot.exe” /file “my-xaml-file-path”

Here I save it as .bat extension. But when I run the batch file only a console screen appears and then disappears. Where am I wrong?

Thanks in advance!

When I use this syntax, only a console blank screen appears for sometime but I visually see no process executing. Please help if somebody can. Thanks!

If there any spaces in btween,it wont run.please copy the exact code of mine in notepad and create the .bat file and try it.Double quotes also very important.

Other option keep the xaml in app-xxx folder and try it.

1 Like

Hi @ ifranity,

use just this "

remember when you open .xaml file will open Studio why open UiPath.Studio.exe and .xaml that will open studio second time ?

Hello for the latest version of Studio CE please use this code:
“LocationOfTheRobot\UIRobot.exe” execute --file “JSON project location”

C:\Users\Yourusername\AppData\Local\UiPath\app-19.9.2\UIrobot.exe execute --file “C:\Users\Yourusername\Documents\UiPath\Project\project.json”

Note that you will have to open Studio and run the project a first time before it works.
If you don’t want other users to be able to open the batch file and to have the code, you can compile the bat to exe using BatToEx Convertor Program.


Hi @vmariejeanne … Can you look on my post Running the bot through batch file , old bot xaml executing although giving another workflow file… Although i was gone through another solution Running bot through VBS … didn’t found solution for posted query :frowning: … Just eager to what went wrong

->Use write text and use file as name.bat
->Use start process to run the bat file