How to connect uipath bot with dialogflow chatbot

@anil.mishra
the error your facing in that the node is connecting to orchestrator. go to azure link https://platform-community.azurewebsites.net/ and create a tenant and this will solve your error

2 Likes

@oumnia_mouad,
the error is occuring because of using older version of dialogflow

2 Likes

Hi @Naveen_tg,

Thank you for your reply. There is no any link to create a new account. When I click the link they asking for user id and password. I already have account in UI path Comunity clouds. Please guide me . Also I am using Dialogflow V2 version.

1 Like

Hi, i am also stuck here with the same error. Please help me.

1 Like

Hi @Naveen_tg I am getting this " Error for “127.0.0.1”: Error: Unexpected status code: 400". Clicking the azurewebsites page just takes me to a link where I am already signed in with only the option to log out. Please help

1 Like

It works for me while working with no proxy.
I update my proxy setting, orchestrator is connected, but somehow dialogflow is not connected, may I know how to work with google behind proxy. Thanks

1 Like

This is very informative.
But I am having a question. Say like 25 customers are using chatbot at the same time and asking pretty much same question. When chatbot is integrated with RPA, if the robot is busy, remaining 24 people should be waiting until the process is finished? or do we need to scale up the robots to handle all the requestes?

1 Like

@anil.mishra, @Scop
Use log in with auth0 , you will be directed to default login page where u can create a new tenant.

1 Like

@Banki,
You have already created the tenant in azure platform and have a setup queue as well right??
And which version of dialogflow your using??

1 Like

@mohamada,
If your using it behind proxy , then you need authenticate the Gcloud sdk with proxy settings

U can achieve those with following commands

gcloud config set proxy/type PROXY_TYPE

gcloud config set proxy/address PROXY_IP_ADDRESS

gcloud config set proxy/port PROXY_PORT

Regards,
Naveen

1 Like

Hi @vinayc,

  1. Yes, the customers should wait until their transaction is fetched by the Bot for processing their request

  2. If you want to reduce the waiting time, you either need to decrease the time taken to process one transaction or increase the number of Bots.
    It is like this:
    (Time taken for one transaction x No. of requests) / No. of Bots = Max wait time for one customer

Hi #dev,
The new version will help you connect node with cloud orchestrator along with dialogflow v2.

To connect with Cloud orchestrator we need tenant name and authorization key,

To get the authorization key
Refer the following link and use postman to get the authorization key.

Hope it helps!

Regards,
Naveen

Hi, I believed I have set up the config.json properly but I receive this error

@Mark_AJ,
This issue is because error while reading the config , check config so that value is of string type , check for parses.
If not solved share your config I’ll check .

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

Okay so it was a parse error my bad, it was included in the code provided. But now I am having this error

Hi @Naveen_tg,
Sorry to bother you again but I was wondering if you could help with this.

So I solved the problem regarding the FATAL Bridge Type Error by uninstalling dialogflow:

  • npm uninstall dialogflow
    and then reinstalling it:
  • npm install dialogflow --save

But now I’m getting this error:

The chatbot recognizes the intent and replies normally, however UIPath doesn’t seem to be doing anything

However I noticed this in the debug console in UiPath:

I would like to add that pendingTasks and persistentRobot is in the UiPath cloud. However, in the console it is saying that orchestrator.amazonSearch() is not a function?