How to connect the robot in Orchestrator settings?

while i am connecting the robot in orchestrator setting, its showing operation was canceled.
Can anyone guide me how to connect the robot in orchestrator?

here you go
Kindly check with these stuffs that would surely resolve your issue
— first create a machine in orchestrator and that machine name should be same as in your system
To get that name go to start-> search as robot-> settings and get the machine name from there and paste the same while creating machine in orchestrator and copy the machine key after this from orchestrator and paste it in your system robot tray and mention the orchestrator url as well
— the. Make sure that we have a robot created in the orchestra with the same machine name and while entering the detail for username and password go to cmd window and type as whoami which will give use domain and username, enter the same in the orchestrator while creating robot
— create a environment now In the robot tab and tag the robot created in the previous step to this environment
— now back to our system in robot tray we have machine key, and orchestrator url mentioned readily and now we can connect
–once after connecting the machine to the orchestrator come back to our studio
go to execute tab and press publish, the project will get published to our orchestrator with a project version
–now come back to orchestrator, go to process tab and create a process by pressing on + symbol at the right top corner,
–there while trying to type itself we will be getting the process name in the process field, the one we published from our studio
–then select the from the drop down and after the choose a environment and create a process
–now we have published and created a process in orchestrator so final step is to run that process
–go to JOBS tab and press play button at the right top corner
and type in the process name and we will be getting the environment name and select the robot under that environment (the robot which is connected to the machine where we want to execute our process)

Cheers @jamunatj

1 Like


while i am creating the robot, its showing error message “no more development robots available”.
if i change the type field as attended instead of studio means robot created correctly.
shall i give type field as attended instead of studio.

1 Like

@jamunatj

Please check below thread and Reallocate robots and then try to create new robot.

1 Like

Hi @jamunatj,

Please give your PC/Laptop Machine ID as Machine Name.

I think you have given a wrong Orchestrator URL. Please give https://platform.uipath.com/ as Orchestrator URL.

Now put the Machine Key you have from Orchestrator.

Now hit Connect.

Hope you will be connected.

Thanks & Regards,
Apurba

1 Like

no buddy
unless it is going to be handled with human intervention WE SHOULD NOT USE ATTENDED type because though we create here a attended type we wont be able to trigger that bot from here in orchestrator…it has to be manully triggered from studio

so try with UNATTENDED robots type and let know for any queries or clarification
Cheers @jamunatj

1 Like

are we facing any issue now
@jamunatj

1 Like

Yes buddy. Still i am facing the same issue. I have followed above mentioned steps.
I dont know where i am doing mistake.

you mean like the error is No more development robot available…
@jamunatj

No , I have created with STUDIO robots type as per your above suggestion, while connecting the orchestrator setting only i am facing the issue like the operation was canceled.

Fine
what is the error can i have that screenshot from studio
@jamunatj


I have attached the screen shot above.

1 Like

Fine
kindly try with the steps in this topic

if you are still with this error kindly let me know pls

cheers @jamunatj

1 Like

lets Kindly try with above steps
if not let us now pls
Cheers @jamunatj

1 Like

did those steps helped us resolving this
@jamunatj

1 Like

Its working fine.Thanks for your support.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.