How to Call Hana Stored Procedure in Ui Path

I tried multiple options to call /execute a Hana DB Store Procedure but it is not working.

Experts please help me with on below example, this how we execute Store Procedure in Hana:
Call “DB_COM”.“Package.2USER::SP_SYS_QRY” ( );

I want execute same from Ui path.

Thanks in advance.

Regards,
Raja

Hello @gaddamr!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff

YOU SOLVED IT ?

I’m Pretty sure,it solved by now. If so sorry.
I would like to suggest mine which worked for me
it needed to call like this
" Call Schemaname.“Procedurename”(?,?) "
Thanks.

Hi @Sa_Ge,

Your reply seems recent enough. Can you please share the details on how are you calling the stored procedure? Are you using the “Run query” activity selecting “StoredProcedure” as the Command type? My procedure follows quite the same structure as yours, but it’s parameter less. Calling it straightly as

" Call ENTREUAUX.““GENERATE_FLES””()"

selectin “StoredProcedure” for the “Command type” throws an

Run query: ERROR [HY000] [Oracle][ODBC][Ora]ORA-06576: not a valid function or procedure name

error, as well as calling it without the double quotes.

Yes i’m Using “Execute Query” activities from Database activity with v1.7.0 syntax is “CALL LIVE_TEST_MAIN.”“AGING_REPORT”“(?,?,?,?,?)” with the parameters in parameters tab as required and it works for me.
as for command type text or Stored procedure both works fine for me.

Hi @Sa_Ge and thanks for lending a hand,

The one I’m using is called “Run query”; I believe we are talking about the same one (UiPath.Database.Activities.ExecuteQuery).

I’m trying the “double quotes around the function name after the service or schema name” format you proposed (which I haven’t seen documented elsewhere) with a parameterless function, that otherwise works fine when run directly from Oracle SQL Developer, and I have other regular SQL queries working against regular SQL queries in this same Studio project, but unfortunately still getting the

Run query: ERROR [HY000] [Oracle][ODBC][Ora]ORA-06576: not a valid function or procedure name

error.

To further complicate / confuse things, during a debugging session Studio changes one of the double quotes from the string to C-style character scaping sequence, that is, to

\"

Literally: one slash character and a double-quote character; I had to type in the slash twice because the forum is scaping the 1st one…

Could you maybe please post a screenshot of the activity with its “contents”, regarding the procedure call and the activity options you have enabled/selected/etc.?

Thanks a lot.

Screenshot attached,

**


**

Since it can call in Database Studio, there’s way to here, Good Luck.
May I know, the syntax to call in Database Studio? Cause I’m just converting the Syntax ,I use to call procedure in HANA Studio into “String” to be able to use.
Hope it helped.

Thanks.