How to automate HubSpot workflows using UIPath?

Hi UiPathians,

I have a use case where I am supposed to automate HubSpot(login, verify the numbers that are updated in it via our other linked applicarion for various properties, etc). Has anyone has experience in doing this?
At this point am just concerned about its feasibility.

Thanks!
Any help in this regard is highly appreciated! :slight_smile:

Hi @Akanksha_Varshney

From my experience, anything can be automated with UiPath.
If I were you, I would simply give it a try, as it should be possible :slight_smile:

1 Like

Hey @loginerror !

Before starting with my journey with UI, I just wanted to get a confirmation from experts that I’ll not be blocked anywhere.

Thanks for the response!

Hi @loginerror
I’d like to ask your help in automating a very simple flow on hubspot with uipath,
I’m trying to add a contact in my list of contacts here
https://app.hubspot.com/contacts/6103709/contacts/list/view/all/?

I’ve a simple sequence that goes like :

  • open browser on the previous link (i assume I’m already logged in and my session is active, so no worries about login error)
  • click a button (create contact), the button opens a side panel (javascript panel, not a new page)
  • I type in the name of the contact, then i save

the problem i face is that when I execute the flow, I see the named written in the input text field and then gets deleted quickly so the flow can’t continue because it will fail to verify mandatory fields !

do you have a lead where may the problem be ?

Hi @sehemy,

I have worked extensively on Hubspot/UiPath now and wanna say that the workflows are quite simple on Hubspot when executed manually but has taken enough efforts from my end to automate.
I tried to execute your use case(which indeed is very simple otherwise) but somehow could not get it done in one go; following error erupted even when element id is the sole property I used to capture the text field(though from the issue you reported though!)
image
Anchor Base has come to my rescue most of the times rather than other simple Activities. Try it and even if it doesn’t work out, probably @loginerror will explain the situation better!
Thanks for posting!