How do i read a specific column in web and click on the hyperlink to download the files?

Hi might need help on this, any help will be appreciated!
how do i read this part which is “file name” on web and click to download the hyperlink below it?


Can you elaborate a little more…

Is it that using filename you want to identify all the links below?

Are you not getting selector for each row of the hyperlink?

Indeally you should be getting one and by changing tablerow property we can get all hyperlinks in table

Can you please check


Hey @monicaong0609 ,
Just try with “Extract Data Table” Activity and observe the preview section .You might get the link So that you can put a for each loop for the DataTable and download the required files one by one.
If not possible Use “Find children activity” then you can get the hyperlinks and click on it.\


Hi i tried using find children but i still doesnt work ://
I think is not possible with extract table activity as is different web but ultimately is still under “File name”


Perhaps you should set target of FIndChildren more outer element such as table, then set Filter string and set Descendants at scope property, as the following, for example. Can you try this?



ultimately i want to download all the links under file name from different links.

Hi @monicaong0609

did you try using For Each UI Element Activity?


Do i need to set any thing for the “Click” activity?


It’s necessary to set item at UiElement (set null at Target)
And please also set UiElement at TypeArgument of ForEach


It still didnt work:////

This is my workflow not sure why it didnt work ://


Can you share your workflow as a file, if possible?



For now, can you try to remove the 2nd line of the selector of FindChildren?



hi thanks for ur help.
I have tried to remove it but it still does not work. It only worked till it opens up the email then it did not click on the link to download


Can you try to turn on Highlight button in the above selector editor, and check if it highlights whole the table?

And also output count of children as the following WrtiteLine? if it’s 0, it’s necessary to review settings of FindChildren.



nothing shows up

could tis be the problem?

Hi @monicaong0609 ,

Noticed you have not used UiExplorer here.

You can Click on the Open in UI Explorer option from the Selector Editor window and then re-indicate the Table.

Then if possible provide the screenshot of the Whole UiExplorer window in here. We will be able to help better that way.

Thank you so much for ur help:)))!! It worked now, the reason why it doesnt run was because of the break activity which i totally neglected abt!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.