How do I Open Browser and extract Web Table using UiPath StudioX?

Hi there,

My Goal & Problem Statement
My Goal is to get UiPath to Open the Browser and Web Scrape the data spanned across multiple pages at:

Ministry of Manpower Singapore

List of foreign worker dormitories

List of foreign worker dormitories licensed in accordance with the Foreign Employee Dormitories Act (FEDA).

I am new to UiPath / RPA and similar to other Users I have the issue whereby I am not able to find the “Open Browser” Activity that used to exist in the UiPath version I used in a short introductory course and web tutorials (Not sure if it is difference in Versions / Environment).

My version of UIPath

StudioX 2020.6.0-beta.93 - 6/22/2020
Community License
EXE Installer

License Provider: Internal
Activation ID: UIP-c82a515fbb

Update Channel: Preview

Microsoft Windows 10 Home 64-bit
.NET Framework Version 4.8

My Project Dependencies

From what I understand, I would need UiPath’s Web Activities Package , which I have installed, alongside its Dependencies, AvalonEdit, Newtonsoft.Json and RestSharp - which I believe needs to be downloaded as well? (Correct me if I am wrong)

What I’ve tried
I have input the Use Application/Browser Resource but am unsure what I am to do next and have tried following the steps mentioned with https://docs.uipath.com/activities/lang-en/docs/n-application-card#section-studiox-nosidebar (with the absence of the Open Browser Activity , I am so lost now as this way looks so different from what I learned).

I am unsure what they mean by “Click Indicate Application to identify the application by moving the mouse to its window and clicking it. If the target is a browser web page, navigate to the page before you indicate the application.”

Does this mean I should be inputting the Navigate Browser OR the Go to URL action before the Use Application/Browser Resource (as seen below):

Any help is appreciated, thank you!

You likely took the RPA developer training which is focused on UiPath Studio. StudioX has a separate “Citizen Developer” learning plan and uses a set of simplified activities. In this particular case, if you want to use Data Scraping, just click the “Table Extraction” button on the ribbon, it will launch a wizard that will walk you through the process and create all the required activities for you.
image

Hi, @AndrewHall thanks for your reply. I tried that but the error message states “this control does not support table extraction”

I think you are running into a case of a bad error message. You typically see that message if the UiPath Browser extension for your browser isn’t installed. Assuming it’s actual text on the web page and not contained in a plugin like Flash, you shouldn’t see that message.

Can you try reinstalling the extension for your browser and see if that fixes the issue? If you can confirm that is the issue, I’ll log a bug for us to fix the error message.

Hi @AndrewHall thanks for your reply. StudioX was giving me issues so I changed to using Studio. I was trying to extract something else but then the error message seen was as shown below:

“Sequence.xaml: Compiler error(s) encountered processing expression “dtVehicleDetails”.
‘dtVehicleDetails’ is not declared. It may be inaccessible due to its protection level.”

Have appended the Screenshot of the Workscreen…

What does that mean?

@irist
Look in the “Variables” window on the bottom. the “Scope” property for dtVehicleDetails is set to “Data Scraping Vehicle Details”. This means that variable is only available for activities contained inside that activity and you are trying to access it in the “Write Range” activity which is outside. To fix this, change the “Scope” value for the variable to the parent Sequence.

Also, can you share details on what issues you were having with StudioX? We’d like to make sure we fix those.