How can you completely disable timeout on an activity (or make it extremely long)?

I am trying use data scraping to get table data from page with thousands of pages. The Data Scraping works fine until the end but throws an exception due to timeout. The largest I can give would be Int32.MaxValue which would be like 30 minutes. I need like 2-3 hours. How can I completely disable timeout for an activity?

Hi @cihanhizlikan,

Int32.MaxValue is equal to 2147483647. It will wait for this much milliseconds. So check your workflow, timeout might have happened from any other activity.

2147483647 miliseconds is like 32 minutes which is not enough for me. I need Data Scraping to run for like 2-3 hours without raising a timeout exception at the end.

Check here

Hmm I miscalculated then. Let me try again. I am going to disable the “go to next page automatically” functionality of the Data Scraping and do it in do while loop if I get another timeout exception. Thanks for the help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.