How can the robot work when remote session is disconnected

I have a robot machine installed in a remote computer. When I run a xaml process when the I’m connected to the remote computer the process runs correctly, but when I close the remote session it doesn’t work.

I’ve seen some other articles that comment on this:(one here, another here & last one here)

I’m rather confused with these articles, but I tried to publish the publish the project, but I get an error message:

Cannot publish project due to an invalid workflow.
Invalid workflow name: LoopThroughContent.xaml.

System.Exception: Cannot publish project due to an invalid workflow.
Invalid workflow name: LoopThroughContent.xaml. —> System.Activities.InvalidWorkflowException: LoopThroughContent.xaml
at UiPath.Workflow.ViewModels.MainViewModel.CheckProjectForErrors()
at UiPath.Workflow.ViewModels.MainViewModel.PackAndPush()
— End of inner exception stack trace —

Find xaml file attached where you will find the LoopThroughContent. I’m not sure what the problem is. Maybe someone can see what is wrong.

ThanksMainPublishError.xaml (37.2 KB)

Regarding : Cannot publish project due to an invalid workflow.

May be you have workflow inside workflow? I haven’t used this scenario before :wink:

or did you just consolidate all your pages?

In terms of publishing I have just tested and initially it did not work. I then copied the single workflow with the OnDemand flowchart to a brand new project and it published fine. The workflow/project file may have become corrupt. Perhaps the project json file is incorrect or missing?


Thanks Richard. Coping into a new project worked for me too.

Now, lets see if I can make it work on a disconnected session :sweat:


Vvaidya, I didn’t think that it would be a problem to have a workflow inside a workflow. I might be confused, but I think in one of the training mention that that it is possible.

I manged to create the Package.

I’m trying now to follow the steps in ‘Publish and run a project package’, but I don’t see the way to get the package listed. Pressing the refresh doesn’t do anything.

Any ideas?

Following the article ‘Start Process From Command Line’, I tried the following command in cmd (comand line):

“C:\Program Files (x86)\UiPath Studio\UiRobot.exe” /C:\Users\FINROB1\Desktop\Share\OnDemand\Main.xaml" /executor /monitored

I tried with inverted comas and without. Also moving to C:\Program Files (x86)\UiPath Studio\ and executing:

UiRobot.exe /C:\Users\FINROB1\Desktop\Share\OnDemand\Main.xaml" /executor /monitored

I don’t see the computer doing anything

Any ideas on what is the right command to use?


All published packages will be listed in “Available” Tab.

This links might help you on this :slight_smile:


1 Like


I can see the package in the Abailable tab. Thanks. Still, the process is not running when the session is disconnected.

This has helped: Start from command line. It is getting stuck on an Excel window, but maybe tweaking the process I might be able to sort it out.