How can I use "Get Row Item"?


#1

I would like to use “Get Row Item” functionality (cf. https://www.uipath.com/activities-guide/get-row-item).
However, I don’t find this activity under “Programming” in the list of activities.
I have tried to use an Assign activity instead with: row.Field(myColumn), but I get a strange error message: ‘.’ expected.
I use version 2016.2.6246.
I want to use this activity to get the values from named columns in a DataRow.


#2

hi @bartc

you will find this activity under “Available->Programmming->Datatable->Get Row Item”.

*if you are still not able to find it then please install the required packages from package manager.

as you already know about “Get Row Activity” by usign above mentioned link is only works on datatable rows so you can use it on datatable for each row activity.

i have also used a for each loop to show the same thing.

GetRowItemSample.zip (6.2 KB)

Please go through with this attached sample and let me know if you have any doubts on this.

Thanks&Regards.!!
Aksh


#3

Thanks for the reply aksh1yadav.
Unfortunately I don’t have this activity under Programming. (DataTable section is not available).
I have installed all the packages from the package manager.
Seems like I’m missing something important here.
Is this not available in the Community Edition?


#4

It is not about community addition or others. You have missed packages installations I guess. In package manger try to search in Available ->All and type in search “UiPath.Core.Activities” and let me know.

And I have mentioned without using this activity as well in the attached solution please check that as well.

Regards…!!


#5

Thanks for your reply.
Searching for UiPath.Core.Activities in the list of available packages yields an empty list.
Here’s a screenshot of how I access the “Manage Packages” screen. It shows I have installed all the packages available.


#6

For those struggling with the same question: do not download the Community Edition Trial, it is broken (at the time of this post in any case, i.e. February 2017). I tested it on Windows 10 and it doesn’t include the correct activities. The correct activities are included with the “UiPath RPA Platform” trial though. Good luck!


#7

Hello,
I want to paste the data in the first emty row .or as i used a write cell then how to find the first empty cell of the column so that write the data into that.


#8

Hello, for get row item activity’s properties - what do I type in row field?


#9

the sample is not working. It throw exception error in the “get row item” activity - Column Role does not belong to table.


#10

Hey @Serran_Neru

  • Row - The DataRow object from which a value is to be retrieved.
  • ColumnIndex - The index of the column whose value is to be retrieved from the DataRow.
  • ColumnName - The name of the column whose value is to be retrieved from the DataRow. If this property is set, then the ColumnIndex property is ignored.
  • Column - The DataColumn object whose value is to be retrieved from the DataRow. If this property is set, the ColumnName and ColumnIndex properties are ignored.

Regards…!!
Aksh


#11

Hey @Cristian_Ivanus
if you are using mine sample and attached .xlsx file then check in the Read Range activity properties the Add Headers is checked or not.

The error generally you are getting because the Column Name does not exists. check your Excel file and above points which ii have mentioned.

AddHeaders - When selected, the column headers from the specified spreadsheet range are also extracted. By default, this check box is selected (set to True).

Regards…!!
Aksh


#12

Add headers checked still get Role not belong to table


#13

Will you be able to share your workflow and let me know the which Excel file you are using ?
Which ever .xlsx file you are using check your column name exists in the first row or not.

Regards…!!
AKsh


#14

Many thanx for your reply
The workflow and file are in the zip file GetRowItemSample.zip above in your post #2 that is second post of this thread I will also send to your mail original downloaded zip file
Regards
smbs


#15

Thanx
Pls see attached file which has error when used
Regards

GetRowItemSample.zip (6.22 KB)


#16

Yes it works for me without any error same like before.


#17


message #8 and #10 mention same problem very strange!


#18

Here is what I get
The problem is mentioned by others in earlier messages
Could it be a problem of which uipath version I am using

Any help would be great
Regards
Smbs


#19

no its not a uipath issue. are u running ur workflow without extracting or ??


#20

The solution is to copy full path of file in excel scope see below


Thanx Script now runs fine
smbs