How can I tell the Robot the path to a local library?

Hi,

I created an own library and used it in several projects on the machine with the studio.
Now I published the projects and want to use them on a production machine where only the Robot is installed. No orchestrator so far.

The robot finds the project-packages, but it does not find the activity package of my own library.
How can I tell the Robot, where to look for the library?

Greetings
Oliver

@OKlink,

You can do that in two ways

  1. Place the same package in the packages folder at the root folder of the UiPath studio application installed

or

  1. Upload the package to the go.uipath.com and then install it in the prod studio :slight_smile:

Hope this helps

Hi HareeshMR,

thank you for your quick response.

Unfortunately I have not been able to test it yet, as I have no rights to place anything in the program files folder and so far no admin was available.
Also I don’t want to upload the library anywhere as it contains internel data.

Is there no way to tell the Robot to look on a specific local path for packages? Like I do in the Studio.

Greetings
Oliver

You have the folder path as below, there you will have many version folders available, you can check your studio version and select the same version to place the package

C:\Users\Your machine name\AppData\Local\UiPath\app-19.7.0\Packages

Thank you, for your support.

I have a folder C:\Users\My machine Name$ but there is no folder AppData inside it. (I checked to show hidden and system files.)

I have now put my library files in C:\ProgramData\UiPath\Packages where studio places the project packages I deploy. This seems to work, but it results in the library being shown under available processes in the robot tray

I have C:\Program Files (x86)\UiPath\Studio\Packages where I am not allowed to write.

I have C:\Users\My Username\AppData\Local\UiPath but there is only a file UiAgent.settings.
.

Then check in Roaming folder instead of local @OKlink