How can I support proxy in HTTP Request activity?

We need integrate UiPath with third-party system via Web Services interface. However the HTTP request should be sent from corporate network to external public server, where a proxy server is required. Unfortunately we didn’t find any tips how to configure proxy server in Web HTTP Request activity. How can the Web HTTP Request activity support proxy server? Any workaround from the activity-level or system-level please?

Another thing to mention is that customer doesn’t use proxy actually, but instead they use automatic configuration script.


1 Like

Hi @FelixJing
I’m using HTTP Request activity for the cloud service via corporate proxy.
It seems HTTP Request activity read Windows proxy settings.

Thanks @tango, after analyzing, I think it is the firewall that blocks the site, not proxy issue. But it is due to “You are using an invalid internet browser! Allowed browsers are: Microsoft Internet Explorer (Version 8, 10 and 11) and Firefox (Versions 51 and 52 ESR)”. How shall we know which browser the uipath http request activity is using? Is there a way we can check that info?

You can use User Agent header in http request to ‘imitate’ browser. Check this link:

@FelixJing I’m sorry, I gave you information that was incorrect.
HTTP Request activity does not support proxy authentication.
If you need to authentication, you use a local proxy.
eg. Fiddler

Can you please specify your solution?
If you can attach your demonstration flow it will be much appreciated!

You can add User Agent to heades in http request:


Regarding proxy, there is header Proxy-Authorization. You can add it in the same place, but you must encrypt proxy login and password. Check details:

Base64 encoder: