How can I solve this problem?

b’{“message”:“An organization unit is required for this action.”,“errorCode”:1101,“traceId”:“00-504f306f71baa420b338c1c71bf4aad4-f84b8dba202893e3-00”}’

1 Like

Maybe this will help. Can you also tell when you are getting this error. More context is needed.

I want to start UiPath process,and I watched this video.

I use this code.


As per error it says you did not provide the organization unit or the folder details to which the api should point to

Please check the same

Which activity are you trying to use?

If in UiPath studio then try with or hestrator http request activity and in the properties you can peovide the folder details


It still not work :cry:
I try this endpoint and this folderpath,is there anything wrong?

Check this knowledge base document from UiPath to get this fixed

Cheers @Wei2

The second link seems to be missing.

You can use the /odata/Folders endpoint to get the organization unit id

It still not work. :cry:

U mean this knowledge base link @Wei2

Yes,this one.
Scenario 2 : If running from Studio and the Robot is not added to any of the environment.
Resolution :

Add the Robot to an environment and assign the required privileges to the Robot role. Refer Managing Environments - Adding a Robot to an Existing Environment for more information.

1 Like

This is the link

Best practice with environment and robots

Cheers @Wei2

Is this the regular HTTP Request activity, or the Orchestrator HTTP Request activity, or are you calling the API from an external app?

The problem is you are not providing the X-UiPath-OrganizationUnitId in the api call. How you provide it depends on the answer to the above question.


In orchestrator http request activity you need to use relative path only…not the complete path…please use only from odata/jobs …

And is the folder exactly matching?

And is it any subfolder then need to gice cullpath


@Wei2 you are trying the query with POST method, please use the GET method.

you can refer the swagger for more details

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.