How can I properly uninstall UiPath community in order to fix UI Explorer?

The UI Explorer does not work in my UiPath Studio. When I try to run the stand-alone version of UiPath.Explorer.Launcher.exe or activate it from tools in UiPath Studio, I get the message “Failed to launch UI Explorer”. When I try to activate UI Explorer from the ribbon, nothing happens. And finally, if I try to activate UI Explorer through “Open in UiExplorer” in an activity like “Click”, I get the error “This program is blocked by group policy. for more information contact your system administrator”.

I can run UiPath.Explorer.Launcher.exe as administrator but then it won’t interact with any other program, unless they also are running as administrator. Everything works fine if I am logged in as administrator user, but I am not supposed to use that since I work in an organization.

I tried removing and reinstalling UiPath.UIAutomation.Activities, but it didn’t help. I tried uninstalling UiPath but it doesn’t work. Can someone please help me here? Thank you in advance.

Hello @nafiseh.padargani,

The community edition is not “installed” like a common way. The best things you can do is delete the entire Studio folder : C:\Users{username}\AppData\Local\UiPath.

And also id needed : C:\Users{username}.nuget\packages

Can you tell us globaly the environnement you are using (windows ? ctrix or RDP ? ) Maybe there is some restriction with your user account.



You could try referencing this topic:
How to fix your Studio installation / Licensing issues


Hi Vidarold,
And thank you for your reply. I removed the files and reinstalled Uipath in the administrator account. My operating system is Windows10. In order to be able to run a program on my own account, it needs to be in a specific folder in C drive. But uipath creates its files in C:\Users{username}\AppData\Local\UiPath which means I can’t run it. If I move the whole UiPath folder to the desired destination, then UI Explorer does not work.

Hi @loginerror
As I mentioned in an earlier reply, UI Explorer doesn’t work on my PC because I can only run programs from a specific folder in C drive. When UiPath downloads dependencies and packages, it all automatically goes to C:\Users{username}.nuget\packages. I don’t have the possibility of running anything from there. Is there any way to change this directory? Cause moving it doesn’t help. I really need to work with UI Explorer.
Best regards

Hello @nafiseh.padargani,

Starting with 20.4.1 release, UiExplorer is available as a standalone tool. You can download it from the Cloud portal, under Resource Center/Other Products section:


Thank you @Florin_Sora

I downloaded the stand alone version of UiExplorer, and it runs. But it is still not possible to access it from UiPath Studio. So I run UiPathStudio as a normal user and whenever I need to use UiExplorer in an activity, I use stand alone UiExplorer and copy paste the selectors to the activity I work on. It is a bit of work but at least I can use UiExplorer.

Best wishes