How can i Ensure that the Excel Macro settings within Excel opened by UiPath allow Add-Ins to be loaded

How can i Ensure that the Excel Macro settings within Excel opened by UiPath allow Add-Ins to be loaded. Sometimes, security settings can block Add-Ins from loading automatically.

@Soudios

This is one way

cheers

Hi

For this we need to configure the Excel application’s security settings

Check the Excel Macro settings.
Open Excel and go to File → Options → Trust Center → Trust Center Settings → Macro Settings.

Make sure that the Macro settings are set to either Enable all macros (not recommended) or Disable all macros except digitally signed macros

Now, you can open Excel using UiPath and test whether macros and Add-Ins are allowed to run without encountering security prompts.

Hope this helps

Cheers @Soudios

the add in is not loading with this way

where i need to pu that on UiPath ? o you have an example plz ?

@Soudios

Its a c# code which you can use in invoke code activity

Cheers

Hi @Soudios

Here are steps you can follow:

  1. Excel Trust Center Settings:

    • Open Excel manually, and go to “File” > “Options.”
    • In the Excel Options dialog, select “Trust Center” from the left sidebar.
    • Click on the “Trust Center Settings” button.
  2. Macro Settings:

    • In the Trust Center dialog, select “Macro Settings.”
    • Choose the option that allows macros to run with “Enable all macros” (not recommended for high-security environments) or “Disable all macros with notification” (to allow users to enable macros on a case-by-case basis).
  3. Add-Ins Settings:

    • Back in the Trust Center dialog, select “Add-ins.”
    • Ensure that the checkbox for “Require Application Add-ins to be signed by Trusted Publisher” is unchecked. This setting is crucial for allowing Add-Ins to load without security prompts.
  4. **Click “OK” to save the settings and close the Trust Center dialog.

how can i do please ?

@Soudios

  1. Drag a invoke code actiity…and from proprties select C# …
  2. then paste the code inside the code area

cheers