HotKeys and Type into not working for sendkeys actions

studio

#1

Hi,

I have to click on an application and then sendkeys Alt+R so that it opens another window in which further actions are to be performed. I tried with hotkeys and type into but its not opening the next window.
image
image

Am not able to perform the steps.
Please help!


#2

hai @anushreebehura,

could you share your workflow screenshot,

Regards,
D.Aravind.


#3

Hi @anushreebehura,

Use “Indicate on screen” where you want to do type into activity, so it will target the particular UIElment.
If you are passing the hot key specify the target using “Indicate on screen”.

Thanks
Girish


#4

Hi @Aravind ,

image


#5

Hi @Girish

I tried that as well, buts its not working.


#6

Try this way:
Use Send Hotkey activity with Alt checked and “r” for the key.
Use indicate on screen and select whole app window, not an element inside the window. (Try to have only the <wnd app element checked in the “Selector” ) … it should work…

This is how to check the selector after clicking the window:


#7

Hi @crimaru,

Its the child window am trying to do action on. I followed your steps but its not working.


#8

If it helps… your TypeInto string is wrong. You are missing “[ ]” and you need to use lowercase r (lowercase r for SentHotKey also)

"[d(alt)]r[u(alt)]"

EDIT Correction: you need to hold down the alt key. I fixed above line…

Additionally, you need to probably change the DelayBetweenKeys to 10 or 20.
Also, make sure SendWindowsMessage and SimulateClick is “unchecked” at first, because they can make those activities stop working sometimes.

Other than that, you haven’t really provided any error messages or a description of what it is doing that is not working about it. So, I’m just assuming there are no errors and that it’s just not typing, which my above solutions address.

Regards.


#9

What error do you get? it just does’t do anything?


#10

@crimaru It does not do anything , hence it throws exception “Cannot find the UI element” for the next step


#11

@ClaytonM Followed all your steps, tried with lower case in sendhotkey and Typeinto, corrected as well (here am doing ctrl+f9 ) so i have used as shown below and for error - It does not do anything , hence it throws exception “Cannot find the UI element” for the next step



#12

@anushreebehura
This might help. Can you open UiExplorer (in the Studio Ribbon), then click the arrow and select the element that throws the element error message. Then, click the Green Check mark to validate. Look at the selector UiExplorer returns and compare with what you are using in your TypeInto or SendHotkey. Also, post both selectors here if you would like.

That might help identify the issue for those looking into helping you.

Regards.


#13

@ClaytonM, Sure I can post that but hopefully I have understood correctly. Still let me know if its different from what i have understood so that i can modify and repost.
Existing:

New:


#14

Thanks.

Selectors look correct to me but I would recommend adding a wildcard to title=“Historiske Handler*”. Can you also verify that the TimeoutMS propterty on the activity is set high enough cause if it’s set really low and text field takes time to load it will throw an error?; Default is 30secs though.

You might need someone to look at it closer cause some websites are difficult to figure out. Here is the help desk incase they can assist better: https://www.uipath.com/contact-technical-and-activations

Regards.


#15

Thanks @ClaytonM :slight_smile ,

It did not work but i found another way of doing the thing and it worked and the issue I will raise to technical support team.