Hidden mode for firefox is not working

I wanna scrape some data from a website in background, so I select the hidden mode in Open browser activity with Firefox and chrome, but the browser window is always visible. IE seems to be working, but doesnt render the webpage i need properly, so using IE is out of possiblities.

Am I missing something here? or Hidden mode is only for IE?

Same problem. Does anyone know a solution?

Hi @Aravindh_Stanley @pduffy

Apparently neither Firefox nor Chrome support Hidden mode. We will update our documentation accordingly.

These options will work for:

  1. IE in non-WebDriver mode
  2. Firefox & Cheme in WebDriver mode

You can read more about the Webdriver Protocol:

2 Likes

Thanks @loginerror, I found out since. Actually, even IE in hidden mode doesn’t work in all cases, I guess this mode is still a work in progress.

Thanks,

Activate the “Protected mode” of IE and it should work every time.

Have you tried this or is it a guess?

I wouldn’t post if it’s a guess. I had the same issue and fixed it when I enabled protected mode.

Hi, what is the cuurrent status of Hidden browser (Chrome) automation? Im trying to do some headless automation but my SimulateClick activities doesnt work.

it is already working now using studio 20.4