HI! how do you use “right-click + Paste in Notepad”?

HI! how do you use “right-click + Paste in Notepad”? not with keyboard shortcuts, I want to try this, as well. tx!

1 Like

Hi @Anca,

You can do it by these following steps :

  • Click with Click type : Right, indicating the Notepad text field.
  • Then add another Click activity with Click type : Left.
  • Click on the “Indicate element on screen” inside the last one.
  • Type F2 to pause the selection.
  • Right Click manually in the Notepad field.
  • When the selection is reactivated, select the “Paste” option.

Hope that helped !


Thanks a lot!

I can’t replicate the process. I press F2, right click in Notepad to show context menu and after the selection of target becomes again active I indicate the Paste item in the menu as target (it has green color). Till now it’s ok. But UIPath doesn’t register this Paste item and instead of that continues in the process of target selection and selects the whole text area of Notepad with green and ignores my selection of Paste in context menu. What am I doing wrong? And how should I cope with anchors in context menu? Thanks for your help.


use F2 to delay uipath capturing mechanism, so that meanwhile you can right click to open paste option and when uipath resumes capture the paste button as click button

1 Like

Hi @HarrySimon,

Normally, the process is as @Kamtaprasad_Jaiswal said.

When the selection of target becomes again active after F2, you click on the “Paste” option (then becomes green) and it will ask you for an anchor (which is blue). You can choose at most 3 anchors.

If you don’t want anchor you can click on “Confirm” in the Selection options once you’ve selected the target (green). The fact that the selection of target suggests to choose an other target (green) whereas you’ve already chosen a target is strange.

Did you try to restart StudioX or with an other Click activity ?

Hope the problem will be soon solved.

1 Like

Does this not work for you?

Link to video because file size exceeded

Also, you can use a Keyboard shortcuts activity to send Ctrl-V to the app


hi! it worked, just wanted to explore all options and see if there is a way of using just one click action instead of 2 or use keyboard shortcuts. I don’t want to miss any shortcut, if it is available :slightly_smiling_face: thanks!


No, my StudioX behaves differently, see attached video.
Keyboard shortcuts act as expected, but I want to try alternative with Click actions. What am I doing wrong?

1 Like

I have the same problem, after clicking f2 and waited for 5 second, I clicked on paste, the paste option was not recorded , instead the whole notepad text window was selected. please see the video below and let me know where I did wrong. Thanks

1 Like

Hi there,

The right-click > Paste option does not work for me also (other options e.g. shortcut key work fine).

I tried to upload the video showing this but I get the error message: “Sorry, new users cannot upload attachments.”

1 Like

upload to youtube. and share the link

1 Like

Ah, right, thanks for the tip, Gary :ok_hand: I see that I get the same result as what you’ve got in your video, so will leave it for now.

1 Like

In the vedio, before Uipath start capturing, the paste option window dissapears. But in may case it remains open till I click on confirm.
Try it once again.

1 Like

I am experiencing problems with both options: When I want to select “paste” (after seeing paste on screen with a green line around it) StudioX selects File instead. I restarted StudioX and notepad but doesn’t help. With keybord shortcuts the password doesn’t get pasted.What am I doing wrong?

Here is the video with paste option available. Still not working. It seems like several other people have the same problem with me. And as you can see, when I chose the paste option, it did paste the password in the notepad. but it didn’t paste in Cosin(UI path)'s video. Don’t know how I can do that.


Hi Grietje,

First - thank you! because I’ve been trying to figure out how to use Keyboard Shortcuts. Until I saw your screenshot, I didn’t realize that it was an available action. I tried it out and it worked for me.

I went back and looked closer at your screenshot and noticed that you have a Right-click action before the Keyboard shortcut Ctrl-V. I think this may be causing the issue. If I change my click from Left to Right, it doesn’t paste the password into Notepad. When I change it back, the password gets pasted.

1 Like

Thank you, Ann, I didn’t use keyboard short cut, I was trying to use mouse to click paste option. and I tried right and left, both didn’ t work. Yours shows click "menu item file’, mine always shows click ‘editable text’.

Gotcha - ok. I am sorry about any confusion. I actually have not figured out how to use the right-click paste option yet… When I try that (along with F2 to pause), the paste window disappears and automatically selects the Notepad editable window.

I ended up using the Keyboard shortcuts. When using the keyboard shortcuts, I left-click first into the editing window (mine displayed “File” because I used the File tab as an anchor tag, but if I don’t use an anchor, it shows as ‘editable text’) - but either option works for me…

Which UI Automation Next package version are you using?

Could you try creating a new project, updating to the latest UIANext version (20.4.1), and see if you still get this?

I can’t reproduce the behaviour you are experiencing