HELP! loop not working

Hi,

I am looking to create a loop where the process will run through to the end and then pick the next company name on the drop down list to run the process. There will be 21 files that will need to be run to be on the save side i have entered my count to 25 until i get further information to confirm the amount of files.
I have created the below screenshot however the process is not looping, can anyone help me or guide me in the right direction.

any help would be appreciated.

Thanks

your activities aren’t inside the loop buddy, drag and drop the try-catch inside the while
@nick.v

3 Likes

Brilliant, thank you @fernando_zuluaga instantly worked :joy:
However the part of the process where i need it to pick the next file down is not working, it picks the same file each time.
image

If i put a hotkey in the first run process to select the second one it will never click the first file, and files don’t get deleted after they have been ran.

so you need to loop trough the selector file, and make it dynamic, each time pick the next one, increment the dynamic variable

At the min i am using click image and click activity is not working on the interface i am using.
I have used this code to make the selector dynamic how it still picked the same file.

image

where am i going wrong here?

Hi @nick.v

Can you show the selector in Uiexplorer screenshot

Thanks
Ashwin.S

change the idx to idx=’"+Counter.ToString+"'
and try again

Hey @fernando_zuluaga its still doing the same thing frustratingly, what else can i try? is there anyother screen you’d like to see to get to a workable solution.

please see below @AshwinS2

this is the selector from the file you need to click? @nick.v

yes thats correct @fernando_zuluaga

and it’s clicking right?

at the min it clicks on the image which is the drop down box then i’ve sen a hotkey to select that file. click activity doesn’t work.

which part you need to click exactly, i can’t understand

image

i need the company dropdown box

image

here you can see a list of the files that will need to selected

did you try with select item activity?

yes i tried it however it is not compatible with the interface as i am using a virtual machine

image

so it’s a really problem, i think we had to try with CV activities

i cant use cv activities as am on the free version of uipath

yes, of course you can. It’s free activities for all of us, install the package
image
then go here and register https://platform.uipath.com/portal_/cloudrpa
then go to ->LICENSES->Other Services, and copy the API Key to use in the ScreenScope