Gsuite Gmail using Service Account

Hello,

I want to send email using Gsuite Gmail activity with authentication type: Service Account Key.
I have provided Service Account email id, user email id and also domain wide access.

Below is the error:

How to resolve this error?

Hey @iamgeet ,

Go to this link https://myaccount.google.com/security , scroll down to the last , Change the “Less secure app access” setting to “turn on access” from “off

Screenshot for reference -

Cheers
Rishabh

Hey Rishabh,

I did the same as you said but I am still facing the same issue.
Any specific role is required for Service account email id or user email id?

Regards,
Geet Maharana

Login to - admin.google.com
then, go to security - advance setting - API Permissions - Enable all the following

Let me know , if this error still occurs.

Thanks

Hello,

Its still not working :frowning:

Regards,
Geet

Any solution, I am also facing the same issue.

Hello,
Now I am able to use Gsuite Gmail Activity using Service Account.

Steps:

  1. Create a Service Account.

  2. Enable Domain Wide Access to the Service Account
    and

  3. Provide Authorization to the Service Account:
    https://developers.google.com/admin-sdk/directory/v1/guides/delegation#delegate_domain-wide_authority_to_your_service_account

  4. I have also added the below scope in OAuth Content Screen as shown below:

So this is working fine for me. Hope it would help you.

Regards,
Geet M

1 Like

thanks. I will check at my end

Welcome :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.