Google Chrome browser PDF is saving always with Browser title name when i used UiPath execution


#1

Hello Team, I have been facing an issue with Google chrome PDF saving option. When i do Ctrl+P and save the webpage into PDF and assigned some name and able to save the webpage in PDF format in manual way. When i performed same actions by using UiPath, my PDF is always saving as google chrome application title name but not taking the name what entered in the save dialog by using UiPath tool.
What i did from my side:
Added and enabled PDF acrobat reader extension for google chrome.
Verified Dot.Net framework.(4.6)
Verified UiPath Chrome extension (which is active and working fine)
Verified Google chrome version (Version 59.0.3071.115 (Official Build) (64-bit))

Could you please some one suggest me what might be the cause and solution.
Your help will be greatly appreciated.


#2

Hi,
Could you please attach your workflow.


#3

it’s pretty simple workflow. i will narrate steps here.
on an opened google chrome browser.

  1. Send Key “Ctrl+P”
  2. Send Key “enter”
  3. SetValue “LocationPath with PDF name”
  4. Click Save button

#4

You can directly hit ctl+s and write the file name and enter.


#5

Oh Nice… i tried that… UiPath is saving all as webpage with .html extention.


#6

Hope you have installed adobe acrobat .when you save pdf from online by default its taking pdf format.


can you try with this site.
http://www.pdf995.com/samples/pdf.pdf


#7

Yes, i have installed PDF extension. it is working fine in my machine with or with out PDF extension.


#8

everything seems to be fine.
How your renaming file.
Using typeinto. is it entering names in filename box ?


#9

I am using UiPath.Core.Activities.SetValue and in the Text field: "C:\Users\username\Desktop\PDFfolder\PersonName1.pdf"
I am passing full path of the folder name and pdf name in the text filed.

While execution, i am able to view that the text field is getting clear and new path with file getting insert. But when UiPath click on Save button then browser is showing an error message “BrowserTitle.pdf” already exist (BrowserTitle is the title name of the google chrome )


#10

Can you try with typeinto activity and make sure to use dynamic name with counter
ex: personName1 .personName2 and delete the BrowserTitle.pdf


#11

I did the same with typeinto as well as SetValue with following dynamic string.
“C:\Users”+iUserName+"\Desktop\Eligibility"+NameID+".pdf"

iUserName is an Environment Variable Name(Global Variable name) to pick system user name.

it is working good in my local machine but not working in remote machine. always taking Browser title name as pdf name.


#12

ok cool.:smiley:
About remote desktop.
It should have network path else just save with name don’t pass file path just to check whether its working or not.


#13

yea tried with only name… not passing full path.still not saving.


#14

Ddpadil, Thank you so much for your response. I figured it out what was the problem.

I will explain here for other team members:
This is the problem of Selector.
I have taken selector with out aaname=File name.

because of this UiPath is always able to enter the full file path but chrome browser is considering default name as file.
hope this info is useful.

Thanks to all who tried to help me on this topic