"Global" scope for variables not available in Data Manager

In this forum topic
Understanding and use case of Global Variables and Constants - News / Vote on Tutorials - UiPath Community Forum
it’s stated that global variables are available if you change the scope of the variable to that one in Data Manager.

Well, as I stated weeks ago in a couple of forum topics (the above mentioned one and Global Variables are not declared after reopening the file - Feedback / Studio - UiPath Community Forum), in my case that scope is not available in the scope dropwdown list.

Nobody is taking care of this after several ways; the staff is not even replying on those topics.

Just to clarify, are you able to assign a Global scope if you create a new process from scratch?

I tried it right now and yeah, I can confirm I can assign the global scope in a project created from scratch.

Now what do I do with my existing projects?

Yes, that’s to be solved. Are your existing projects using Windows compatibility?

Can you also double-check that the existing projects aren’t of type “Library” (project.json → designOptions → outputType = “Library”)? As per documentation, Global variables can’t be created in Libraries.

Sorry, sorry, I tested it further and:

  • The blank, new project I tried after your first question and the one that allowed me to select the “Global” scope for my variable was a “plain” Windows project.

  • My existing project, the one I was complaining I cannot assign a “global” scope to my var, is a Windows-legacy project.

  • If I create a new, empty Windows-legacy project from scratch I can’t assign any “global” scope to vars.

And no; they are not a “Library” type project. All them are of the “Process” kind.

Thanks again and sorry for any inconvenience.

1 Like

Global variables are not available in legacy. This is by design of the limitations of net461.

As stated earlier, only windows and cross-platform will get new capabilities.

And in the non-legacy ones you cannot rename them, only delete and create them again, which render them almost unuseful. I wonder why this limitation, but oh well.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.