GIT integration

How do you do this with SVN or TFS? Is there not the same problem?

With TFS you checkout (lock) the file by default, so youvreally have to try to create a conflict (outside of branches merging).

Ok that’s true, is see the problem. But is this a problem of UiPath?

It kind of is, actually - not directly caused by UiPath of course, but the fact that commit conflicts will happen on a regular basis if there is no file locking due to the nature of Git. UiStudio needs to be able to handle that in some way, otherwise integration would be pretty useless.
You can already see steps made to deal with it - looks like the filediff that’s available in the newest version is, I think, a step towards what’s needed to make Git integration work.

1 Like

+1 as we use GIT as well!

See here :slight_smile:

5 Likes

GIT is out in beta, so moved it to completed. Waiting for feedback :slight_smile:

3 Likes

Woo hoo! Well done guys, love this!

1 Like

+1 - well done, it would be amazing if it could handle single sign on authentication, or Windows Git Credential Manager for enterprise grade Git installation on Azure DevOps for example ! Right now it seems only basic username/password is supported.

Agreed! Haven’t read anything that is in the works, wondering if there is a workaround for this…

Not really a workaround but we use the git command line to push pull and clone, but this is really not ideal, we will probably stay with TFS for now. It would be great to see this feature in UiPath Studio for GIT to make it more enterprise ready, a lot of companies use Azure DevOps to manage Git with single sign on to their active directory.

Hi @Ollie

According to our documentation, it should be possible to at least use SSO Authentication method with a personal token:


There is also this behaviour here reported by another user, but I’m still researching the details:

Something to test though if you feel like it :slight_smile:

3 Likes

Thanks you ! That’s a great workaround ! It is not truely SSO as it does not use our company login page but using an individual token as a password worked for us.

1 Like

my hero!!!

When trying to make Git and AzureDevOps to connect there seems to be a bug when using repo’s with a space. e.g.: https://tfs-********_git/Robotic%20Proces%20Automation is not accepted by Studio, while
https://tfs-*******_git/RoboticProcesAutomation is, as we are using the first format as standard this bug holds us back from integrating.

Result when using the standard format with %20:
GIT: UiPath.Studio.Contracts.RecoverableException: Unable to clone from the given repository. Please make sure that the remote is available and try again. —> LibGit2Sharp.InvalidSpecificationException: malformed URL ‘https://tfs-*******_git/Robotic Proces Automation’

Is this a known bug?

Hi @Fritsie

Welcome to our UiPath Forum! :slight_smile:

What is your version of Studio? It seems to be working on TFS repository on Studio 2019.5.

1 Like

2019.4.2, downloaded yesterday, so I assumed that was the newest version.

Och, if it is an Enterprise edition we are talking about, then yes, 2019.4.2 is the latest Stable version.

2019.5 is available via the monthly preview otherwise known as the Community Edition :slight_smile:

Yes, I am using Enterprise here. I assume this is solved in 2019.5 then, when will that be released to Enterprise?

I would definitely create a ticket with our technical support for this issue. They will be able to assist you directly and even escalate the issue for it to be fixed with a patch if it comes to that.

1 Like