Getting this issue while running a sample java program by using java activities in UIpath Java Scope: Error intializing Java : System.NullReferenceException: Object reference not set to an instance of an object


current java version in my machine : java version “1.8.0_221”
and i have given path in javascope activity like : “D:\Program Files\Java\jdk1.8.0_51”
if i am giving path like this “C:\Program Files\Java\jdk1.8.0_51\bin\java.exe”. i am getting error like “javalibrarypath Invalid”.
please have a look on attached screen shots.

You have to give path upto bin folder :slight_smile: @sunilraju,

Or if your path is set in the environmental variables, then just leave it blank . It will work

I have tried what you said above and getting same issue. please find the below screen shots once

If the path is not correct, then it will throw the error as path invalid, but this is a new and strange error. Can you try upgrading or downgrading the JAVA packages @sunilraju

yes i have done the same thing yesterday. Uninstall the jave package which i installed earlier and then install it newly.
but again facing the same issue.
Have you tried the same which i did in your machine?

Can you try running JAVA scope alone in your machine @sunilraju?

If it runs without any error, then it is not the issue with JAVA scope

i have taken only javascope and inside javascope added message box.
still getting same issue, please find the below screen shot

Do you have flash installed in your machine @sunilraju?


which flash?

May be a pluggin in Firefox or a adobe reader flash @sunilraju. or you have some permission problems to read the folder from external applications :slight_smile:

This thread have all the solutions related to the problem… please go through this

Okay then let me try in my machine once . and let you know if still issue exists.

Sure @sunilraju

getting same issue after running the same UIpath automation through “Run as Administrator”.

Any Suggestions or any one knows or facing same issue.


I am facing same issue and then i provide the java path till JDK its work one time then ageb showing same error.
Could you please let me know which java version is required to run java scope and any thing else should i try .

Thanks and Regards,
Anurag Sharma