Getting stored procedure output error value is too large to bind

Hi @avldev

Could you provide more information?

  • Studio version
  • Activity package version
  • example project if possible

It is really impossible to debug the issue with limited information :slight_smile:
Feel free to also update your activity package to the most recent version if you didn’t yet, the issue might be solved already.

My Studio version is 2018.2.3
Hi, my activity package is already updated as you can see below screenshot.

I created simple Stored Procedure which insert data and there’s one output (which is VARCHAR2).

And here’s my sample work

My parameters:

The dtOutput variable was set like this:

1 Like

Hello @loginerror

Also, I tried changing the data type of my out parameter in my stored procedure to NUMBER and in uipath parameters to Int32, it was working properly, but if I change both data type to VARCHAR2 and String, the error “Value is too large to bind” shows up.

i am having the same error.

Hello Francisco,

unfortunately, UIPath doesn’t have solution to that yet.

Hi everyone,

Since several packages became open source (including the Database one), you can post your bugs on our Community GitHub. The one from this thread is posted over here:

The code of the package can be found here:

And lastly, the post that introduces the change is here:

This issue has been fixed in UiPath.Database.Activities 1.4.0. Check out more info here UiPath Open Source Activities January 2021 release

1 Like