Getting error - The message filter indicated that the application is busy. (Exception from HRESULT: 0x8001010A (RPC_E_SERVERCALL_RETRYLATER))


I am running word template update bot and getting error in replacing the image.
This is the error message:
The message filter indicated that the application is busy. (Exception from HRESULT: 0x8001010A (RPC_E_SERVERCALL_RETRYLATER))

Any idea how to resolve it?


What’s the sequence of your applications? Could you please post a screenshot of the sequence?

Open Excel file first, then the Word file. Because the Replace Text activities occur in the Word file.

1 Like

Hi, I have already tried that but issue remains the same. I also tried to put delay but no help there.

can you share your solution here? Edit: I mean the actual project file.

I am getting message that New User cannot upload attachments. I think I can only share images at this time.

I see. Sorry I am not sure how to solve this.

Hi Aditya,

I received this error also, but for me, it turned out to be that I had the Word document open because I was reviewing it to get the information that needed to be copied. Once I closed the word doc, the automation ran through successfully. My thinking is when it tried to run while the Word doc was open, the Word doc may have been read-only, so it couldn’t be edited (application was busy)…

Hi Ann,

Thanks for the response. I did checked all the open word files and processes however I couldn’t find any. Even restarted my laptop, just to be sure. I think it has something to do with the version of Word on my machine. I am still researching it online but no solution yet.


Hi Adi,

I apologize… I just did a test to see what will happen if I leave my Word document open when I run the automation, and it did not give me any errors. I also tried swapping the order of the applications around, but after several attempts I can’t reproduce the error.

So even though all I did was close the Word doc, I don’t think the open document is what caused the error for me - it must have been coincidental that the issue went away when I reran it…

BUT - I’m curious if you download and run the solution, if you would still receive the error. If you do get an error, then there’s more research to do, but if you don’t get the error, you can compare the actions in your project to the solution…

I’ve run the solution provided by UiPath and the error with busy app still occurs, so the issue is not in the project

Interesting - I did a general Google search on this error The message filter indicated that the application is busy. (Exception from HRESULT: 0x8001010A (RPC_E_SERVERCALL_RETRYLATER))

It does seem to have something to do with processes that are trying to close the Word application… but I can’t find a clear resolution… I wonder if there’s a process that is still running in the background that could be ended using Task Manager?

I just found a solution in a UiPath forum from December 2019. I don’t know if it is Studio or Studio X specific and it doesn’t seem ideal, but maybe a workaround?

Same goes for me. So it is not linked with the UiPath project. May be some word issue but cannot be sure.

I have checked this before but don’t want to try it as I wanted to complete this on StudioX as mentioned in Reboot your skills program :slight_smile:

I will give it a try now.

Hi @aditya_sharma. Could you please tell me if you were able to fix your issue as I am getting the error same message when running the solution provided. Thank you.

Hi @Yannie, I was not able to fix this issue. I tried almost all the things I can find on blogs and internet but no luck.