Getting Error popup "A task was canceled" while connecting Uipath and orchestrator

Hi,

I am getting error popup while configuring orchestrator in Ui Path robot setting. I am using orchestrator CE 2018.3.1 version.
orchestrator URL- https://platform.uipath.com

Please Help…

I was trying to connect orchestrator CE and Uipath studio. After entering orchestrator URL and key I clicked on Connect button and got popup saying “A task was canceled”.
Check the attachment below:
orch%20error

See this thread:

HI All,

I tried all the workaround. But i am getting the error been mentioned. I am using Orchestrator URL : https://platform.uipath.com and version of UI path 2018.4.1

Please help me in getting this error fixed.
“A task was cancelled”
status: Error connecting to robot service

Another solution that worked for another user:

2 Likes

Hello Chaitra,

did you find a solution to the problem?

im having the same issue and tried everything so far

Hi @CP_automation

I believe you could try if this would help:

Hello @loginerror

thanks for your answer! I tried that already, still doesn’t work though :confused:

Could it have something to do with my BOT being on a Virtual Machine? I sure have correct Domain + Username details and even tried the proxy config settings but it still sais “task has been canceled”.

Cheers,
Felix

Hi @CP_automation

Is it the Community Edition (just making sure)? If so, I suppose it still happens on 2019.4 (our latest stable version)?

One suggestion would be to try to reinstall the 2019.4 from scratch to let it clear the environment and potentially corrupted installation. I don’t have a lot of hope for this solution though.

I’ve also seen that my solution from above is not 100% matching your issue. Better reference would be this topic here:

It is outdated, but contains a post marked as solution to the exact same issue.

Lastly, if the issue is with the Enterprise edition, you can also contact our technical support directly and they will be happy to assist you.

Hi @loginerror

thanks for your answer!

It randomly started to work! For some reason UiPath cannot read IMAP Mails anymore now and the same issue as

is occuring now… ill continue to try and find out what the problem is!

cheers

1 Like

I tried several solutions, but none work.
Forget Wifi network and connected again, it worked. Thank you soo much.

1 Like

None of the above solutions worked for me and I was getting the same error “A task was canceled.”

The robot finally connected to Orchestrator after I disconnected my company’s VPN. Hoping that it won’t block me from using my client VPN in the future, otherwise I won’t be able to work from home.

I found the solution. The issue is with the machine name while provisioning the machine. Use the full computer name when giving the machine name.

Hi @loginerror

There are so many posts on the UiPath forum addressing this “A task was cancelled” issue.
Apparently there’s no fixed solution for this. Some methods work for some people and some don’t.
I am interested in knowing the root cause for this error. So if you can help me with this that would really be great. :slight_smile: Do let me know if there’s no single root cause but multiple ones.

Thank you

Hi @Ibs_ibzy

I believe the main reason would be the discrepancy between the Studio and Robot version on your machine. Please see these topics, each containing a post marked as a solution:
https://forum.uipath.com/search?q=A%20task%20was%20cancelled%20status:solved

The general solution would be to give your Studio fresh install. You can follow the guide here:

1 Like

Hi @loginerror

I apologize for such a late response.

Thank you so much for the information and the collation of the related topics with solution. Really appreciate that :slightly_smiling_face: