Getting error during Calculate Client Security Hash Walkthrough - System error at initialization: Object reference not set to an instance of an object. at Source: Assign


#1


#2

check if in_dtWIList has any rows in it.


#3

Thanks PD2. I tried to get count by using (dtExtractData.Rows.Count - 1).ToString but it fails there. I assume this is because there are no rows getting fetched? I am using data scrapping wizard and it seems to be have identified the table properly. Not sure why no data is getting returned.

I even created a dummy workflow just to check if the data scrapping was working. Turns out it is not working and I am not sure why and what needs to be done ( I tried changing the MaxNumberOfResults variable, the output variable etc)


#4

First check your data scraping wizard. and then check whether if in_dtWIList has data using “in_dtWIList is nothing” in if else activity. If it contains data then check your dt_WIList contais rows in similar way. Hope this would be helpful.


#5

@Sachin_Tayade: I hope you are using this Data Scraping
image

I hope you are using IE browser, using the wizard to scrape, while preview data enter the MaxNumberOfResults to 0; Try getting the scrape in a test workflow first to verify it is working.


#6

Thanks I was using the data scrapping wizard. It has something to do with how you record it the first time. I was able to get the data after multiple tries. Still think that it has something to do with the maximum number of records setting.