Getting entity record filenames not working

Hi All,

I am currently working with Data Service from UiPath and trying to get the Filename from a field in Data Service. This is done by the activity ‘Get Record by Id’ and assigning the result to a variable ‘recordOutput’.
In the log message I am able to type the field and the ‘.Name’ but it will give an error that the method is not found eventhough it was possible to type it.
image
Error message:


Also it is possible to get the value in debug mode and use the Immediate panel.
Immediate panel:
image

Does anyone know how to fix this? I saw some post about it from more than a year ago that UiPath will fix it “soon” but it is still not working.

Greetings,

Ko

Hi @Ka_Ho_So ,

Could you share the schema of your Data Service,
Just the schema details from the top would be fine.

Thanks

Where do I find the schema?

Click on
image
Manage Entities,
Hover over your entity and it would come up in a tooltip kind of popup. you can screenshot that and share.

Else You can open the entity in Orchestrator and get it from there.

You are trying to access JobRequestForm.Name?
Can you check if the entity attachment jobRequestForm has a property called as Name?

You’re able to get it while you’re debugging it, did you try to cast this into String.
That might help.

The property Name does exist for jobRequestForm but after using you get the error “method not found…”.

Casting to string is not working it still give the same error of “method not found…”.

Hi @adiijaiin and @Ka_Ho_So,

This is a known issue and was recently fixed with the new studio desktop version. Can you please check if you are still encountering this error?

Thanks!