Getting "Connected Unlicensed" with Uipath Assistant for new community orchestrator(no Default folder, having only shared folder)(Confusion in machine configuration)

Hi Pablito,

As you suggested , I have deleted one user and kept only one user and tried. But Still , it’s connected unlicensed. My question is, In the DESKTOP-9OT0RJI folder I have linked the created machine but in the tenant–>Robots page, robot is not linked with machine, why is that so… That’s why I think it’s unlicensed. Please refer below screenshot. Kindly help me

Hi @Stalin_R,

Can you hover over the Connected, Unlicensed error in UiPath assistant and share the message you are getting ?

Telling use interactive login

check if you have allocated license. If not allocate the same

Hi @Stalin_R ,

I guess Robot Key authentication is disabled in your orchestrator.

Go to Tenant > Settings > Security tab.

Uncheck, “Enable user authentication, disable robot key authentication” option to connect your machine using Machine Key.

You can refer these URLs and check if you have followed all steps as stated.

Hi @Stalin_R

I think the solution provided by @jithin.gangadharan is the right solution, as per this topic:

Basically, Assistant does not understand unattended licenses yet.

With that said, it’s still possible to connect your robot unattended and using sign-in as long as you configure both attended and unattended for the user, see here for a vanilla setup on a fresh account.

1 Like

Thanks Maciej,

For Unattended - Now it’s connected and licensed . After disabling “Enforce User authentication, disable robot key authentication” option from Tenant–>Settings–>Security

For Attended - Simply sing in from UiPath Assistant, it’s auto creating the attended robot and machine template in orchestrator and “Connected and Licensed”

This url is helpful :Assistant - robot is unlicensed - #11 by Oana_Georgiana_Vasile

Let me publish process and check the processes,job and triggers with this unatteded bot and mark this as solution

Thanks you ,

1 Like

Hi Maciej,

I have published one of the process from my studio to orchestrator as tenant feed. But I am facing issue while creating process. Could not create process in any folder. Kindly help me on this

Hi @Stalin_R

I guess user is only having Robot permission for the folder. Go to Tenant > Folders > Folders and check check the permissions for user. If user is having only Robot permission, click on the Edit Role icon and change the permission to “Folder Administrator”.

Hi Jithin,

Thank you so munch man. It worked. I can create process, job and triggers. I am marking this topic as solved

1 Like

Hello Jithin,
I have disable the " Enforce User authentication, disable robot key authentication" and trying to connect. But still it showing Connected and unlicensed (The Machine key is linked to another Machine). Could you help with this issue.
Thanks in Advance…

Hi Sweetha , How did you disable that? I am getting this notification

Hello Naveed,
Check this URL— Assistant - robot is unlicensed - #11 by Oana_Georgiana_Vasile
Thanks and Happy Automation…

1 Like

Any Update?

Hey Swetha , after disabling that checkbox , My BOT got connected and licensed. Please make sure that you are using machine key of template machine for unattended BOTs

Hi Swetha,

Bot will be connected and licensed only if you are using the correct Machine Key. Kindly use the machine key of template on which Robot license was allocated to connect to the orchestrator.

You cannot connect 2 machines to orchestrator using same Machine Key. Disconnect the other machine and then use the key in this machine.

Thankyou Naveed…

Thank you for the reply Jithin, i am able to connect now.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.