Get Text 'text .00 is not a valid value for Int32

Hi there,

I’m trying to extract a value from an application; initially I tried to do int32 as the variable, and then i put an if statement to say that if the number was <= 0 then the process ends. However, I get the above error mentioned “Get Text .00 is not a valid value for Int32”. I’m unsure of how to resolve this.

Any help is always appreciated, thank you!

Get Text returns a string value, so you have to give it a string variable. Then you can convert it to an integer if you want.

Anyway, “.00” isn’t a valid integer. Integers are only whole numbers ie 1, 2, 3, 4, 55, 60, 9999999, etc. You can’t have decimal points on an integer. If you need decimal points the correct datatype is double.

So if you use Get Text to put the string value into a variable named myStrValue, and want to convert it to a Double value…


So you can do…

If CDbl(myStrValue) <= 0

1 Like

@postwick This is exactly what i needed, thank you so much!

I was able to extract the value, and using the if statement you provided above (If CDbl(myStrValue) <= 0) and added a log message in both my Then and Else. For some reason, because the value is .00 its going into Then Section. I also tried doing .00 just to see if that would change anything and it didn’t

It is providing the correct result for me. Are you sure the value you’re getting is “.00”? You should Log Message it to see.


That’s so weird! Yeah it seems to come up as .00 (see below)


I just realized my mistake, what you told me to do worked perfectly I just had my Then and Else mixed up. Thank you so much @postwick for your help!!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.